You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by "stack (JIRA)" <ji...@apache.org> on 2009/04/28 09:58:30 UTC

[jira] Commented: (HBASE-1304) New client server implementation of how gets and puts are handled.

    [ https://issues.apache.org/jira/browse/HBASE-1304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12703528#action_12703528 ] 

stack commented on HBASE-1304:
------------------------------

Couple of comments:

Is multifamily a boolean that says whether a HCD has more than one?   Can't client just count the families in an HCD rather than set an attribute?

>From HConstants:

"Max length a family can have because of the limitation in TFile."   Shouldn't this define be in KeyValue if it isn't already?

Whats happening in KeyValue?  Seems like most of added code is stuff already in KV?  There are conflicts that need resolving.  Looks like in most cases you want to keep what is in trunk.

This method:

{code}
+  public void set(final KeyValue kv){
+    this.bytes = kv.getBuffer();
+    this.offset = kv.getOffset();
+    this.length = kv.getLength();
+  } 
{code}

is a duplicate of a copy constructor from earlier in KV.

newCommit is not the best name for a method; can we think of something else.  Takes different arg. so maybe just call it commit?

GetColumns vs. GetFamilies, vs. GetRow: why have 3 types?  Why ain't a get of all on a row a Get with no family spec?   Why ain't a get of a column a Get with an explicit column spec?  And a get on a family, a get with a family as opposed to column spec?  Why not a single Get class?

What is GetTop?  There is no class comment explaining it?  How does this differ from get n versions?

RowUpdate should be carrying KeyValues?

newGet is not going to work.  We'll be stuck with this method name for ever.

Looks like we start using byte [] for family when we get serverside.  Family class just client side -- and sent over the wire -- only to be made into a byte []?  Should be sent as byte [], not as Object?  We should be slim as possible in RPC -- byte arrays where we can -- to save on net traffic

Seems like bunch of isDelete code belongs in comparators?









> New client server implementation of how gets and puts are handled. 
> -------------------------------------------------------------------
>
>                 Key: HBASE-1304
>                 URL: https://issues.apache.org/jira/browse/HBASE-1304
>             Project: Hadoop HBase
>          Issue Type: Improvement
>    Affects Versions: 0.20.0
>            Reporter: Erik Holstad
>            Assignee: Erik Holstad
>            Priority: Blocker
>         Attachments: hbase-1304-v1.patch
>
>
> Creating an issue where the implementation of the new client and server will go. Leaving HBASE-1249 as a discussion forum and will put code and patches here.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.