You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hive.apache.org by "Lefty Leverenz (JIRA)" <ji...@apache.org> on 2017/04/01 08:58:41 UTC
[jira] [Commented] (HIVE-16336) Rename
hive.spark.use.file.size.for.mapjoin to hive.spark.use.ts.stats.for.mapjoin
[ https://issues.apache.org/jira/browse/HIVE-16336?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15952134#comment-15952134 ]
Lefty Leverenz commented on HIVE-16336:
---------------------------------------
+1 for the parameter descriptions.
Thanks for the formatting fix, [~csun].
> Rename hive.spark.use.file.size.for.mapjoin to hive.spark.use.ts.stats.for.mapjoin
> ----------------------------------------------------------------------------------
>
> Key: HIVE-16336
> URL: https://issues.apache.org/jira/browse/HIVE-16336
> Project: Hive
> Issue Type: Bug
> Components: Configuration
> Reporter: Chao Sun
> Assignee: Chao Sun
> Attachments: HIVE-16336.0.patch, HIVE-16336.1.patch
>
>
> The name {{hive.spark.use.file.size.for.mapjoin}} is confusing. It indicates that HoS uses file size for mapjoin but in fact it still uses (in-memory) data size. We should change it.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)