You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@wicket.apache.org by "Martin Grigorov (JIRA)" <ji...@apache.org> on 2015/08/27 22:33:45 UTC

[jira] [Commented] (WICKET-5976) FeedbackMessages first(int level) poorly named and documented

    [ https://issues.apache.org/jira/browse/WICKET-5976?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14717479#comment-14717479 ] 

Martin Grigorov commented on WICKET-5976:
-----------------------------------------

No need to estimate the hours :-)
Just send us a patch with the improved javadoc and we will apply it!

Renaming the method is not an option for 7.x. Only 8.x (not yet started) may have API breaks.
Thanks!

> FeedbackMessages first(int level) poorly named and documented
> -------------------------------------------------------------
>
>                 Key: WICKET-5976
>                 URL: https://issues.apache.org/jira/browse/WICKET-5976
>             Project: Wicket
>          Issue Type: Improvement
>          Components: wicket
>    Affects Versions: 7.0.0
>            Reporter: Robert Bain
>            Priority: Minor
>   Original Estimate: 3h
>  Remaining Estimate: 3h
>
> FeedbackMessages method public final FeedbackMessage first(int level) has documentation specifying that it "Retrieves the first message matching the specified level" when in fact it calls FeedbackMessage's isLevel(int level) which "Returns whether this level is greater than or equal to the given level." which is also poorly named as it doesn't return whether the FeedbackMessage is of the specified level; it returns if it's of the specified level or more severe.
> In my opinion both the current functionality and the functionality to return only those messages of a specified level are desirable. A minimal solution is an update to the documentation of FeedbackMessage's first(int level) method but I think the methods should be renamed to say what they actually do.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)