You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avro.apache.org by "Ryan Skraba (Jira)" <ji...@apache.org> on 2020/06/19 11:48:00 UTC

[jira] [Comment Edited] (AVRO-2865) Security vulnerability caused by plexus-utils:1.5.6

    [ https://issues.apache.org/jira/browse/AVRO-2865?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17140470#comment-17140470 ] 

Ryan Skraba edited comment on AVRO-2865 at 6/19/20, 11:47 AM:
--------------------------------------------------------------

The maven 2 compatibility plugin is dragging in this old version.  Maven 3 has been out and widely adopted for almost 10 years, we can probably safely bump.


was (Author: ryanskraba):
Maven 

> Security vulnerability caused by plexus-utils:1.5.6
> ---------------------------------------------------
>
>                 Key: AVRO-2865
>                 URL: https://issues.apache.org/jira/browse/AVRO-2865
>             Project: Apache Avro
>          Issue Type: Improvement
>    Affects Versions: 1.9.2
>            Reporter: Hans Heisig
>            Priority: Major
>             Fix For: 1.9.2
>
>
> According to X-Ray scanning of our dependencies, the current version of the *maven avro plugin* is due to the old plexus-utils version vulnerable to CVE-2017-1000487 and [https://github.com/codehaus-plexus/plexus-utils/issues/3]
>  
> Both have a high severity and can be solved by upgrading plexus-utils to > 3.0.23.
> Could you please consider this in a potential new version?
> Thanks



--
This message was sent by Atlassian Jira
(v8.3.4#803005)