You are viewing a plain text version of this content. The canonical link for it is here.
- [sis] branch geoapi-4.0 updated (83ec78c -> 6580779) - posted by de...@apache.org on 2021/08/01 12:14:39 UTC, 0 replies.
- [sis] 01/03: Move the `Compression` enumeration close to `Inflater`. It would allow sharing compression algorithms with other image formats in the future if needed. - posted by de...@apache.org on 2021/08/01 12:14:40 UTC, 0 replies.
- [sis] 02/03: Rename `Uncompressed` as `CopyFromBytes` because this class can be used even for compressed data. - posted by de...@apache.org on 2021/08/01 12:14:41 UTC, 0 replies.
- [sis] 03/03: Ensure that the chunk size are not greater than buffer capacity. - posted by de...@apache.org on 2021/08/01 12:14:42 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add PackBits compression. - posted by de...@apache.org on 2021/08/02 21:53:29 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (4db6a33 -> faebd0f) - posted by de...@apache.org on 2021/08/09 11:39:17 UTC, 0 replies.
- [sis] 01/03: Add a `ChannelDataInput.skipRemainingBits()` method. Minor clarifications in Javadoc and in comments. - posted by de...@apache.org on 2021/08/09 11:39:18 UTC, 0 replies.
- [sis] 02/03: Add `ArgumentChecks.ensureDivisor(…)` method. - posted by de...@apache.org on 2021/08/09 11:39:19 UTC, 0 replies.
- [sis] 03/03: Add CCITTRLE compression. This addition requires partial support of multi-pixels packed images In the case of images compressed by CCITTRLE, they are bilevel images with 8 pixels per byte. Fields have been renamed: "element" is now reserved to elements in arrays of primitive type. - posted by de...@apache.org on 2021/08/09 11:39:20 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Fix a case where `GridDerivation` was not expanding the extent to an integer amount of tiles. Fix a `NullPointerException` when `gridToCRS` is null (i.e. when data have no known location). - posted by de...@apache.org on 2021/08/09 21:46:35 UTC, 0 replies.
- [sis] branch visual-test updated (3b50a06 -> 3b457cb) - posted by de...@apache.org on 2021/08/09 21:57:46 UTC, 0 replies.
- [sis] 01/02: Optionally show pixel grid and tile grid. - posted by de...@apache.org on 2021/08/09 21:57:47 UTC, 0 replies.
- [sis] 02/02: Checkstyle fixes. - posted by de...@apache.org on 2021/08/09 21:57:48 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (3b223ec -> 3bc831a) - posted by de...@apache.org on 2021/08/11 23:32:43 UTC, 0 replies.
- [sis] 01/04: Consolidation: - Safer rounding of subsampling values. - Add test and clarifications in Javadoc. - posted by de...@apache.org on 2021/08/11 23:32:44 UTC, 0 replies.
- [sis] 02/04: Renamed `selectedBands` as `includedBands` because a band may be loaded despite not being selected by user. - posted by de...@apache.org on 2021/08/11 23:32:45 UTC, 0 replies.
- [sis] 03/04: When reading multi-pixels packed images, restrict sub-region to element boundaries (typically byte boundaries). It allows the `SelfConsistencyCheck` test to pass for random sub-regions. - posted by de...@apache.org on 2021/08/11 23:32:46 UTC, 0 replies.
- [sis] 04/04: Group together the display of statistics about execution time. - posted by de...@apache.org on 2021/08/11 23:32:47 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (3bc831a -> 2cef81f) - posted by de...@apache.org on 2021/08/13 18:37:39 UTC, 0 replies.
- [sis] 01/03: Rename `samplesPerElement` as `pixelsPerElement` (this is not the same value in `SinglePixelPackedSampleModel` case) and consolidate the way that this value is computed from the `SampleModel`. - posted by de...@apache.org on 2021/08/13 18:37:40 UTC, 0 replies.
- [sis] 02/03: Add a `GridDerivation.maximumSubsampling(…)` method and use it in `TiledGridResource` for disabling subsamplings on axes where it is not supported. - posted by de...@apache.org on 2021/08/13 18:37:41 UTC, 0 replies.
- [sis] 03/03: Provide a slightly optimized implementation of `ChannelDataInput.readBit()` method. - posted by de...@apache.org on 2021/08/13 18:37:42 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (2cef81f -> 63e31b0) - posted by de...@apache.org on 2021/08/16 13:32:38 UTC, 0 replies.
- [sis] 01/04: Support a few tags from TIFF Section 12: Document Storage and Retrieval. - posted by de...@apache.org on 2021/08/16 13:32:39 UTC, 0 replies.
- [sis] 02/04: Support TIFF FillOrder=2. - posted by de...@apache.org on 2021/08/16 13:32:40 UTC, 0 replies.
- [sis] 03/04: Take in account the Differencing Predictor (for now, only "none" is supported). - posted by de...@apache.org on 2021/08/16 13:32:41 UTC, 0 replies.
- [sis] 04/04: Add LZW compression (read only). - posted by de...@apache.org on 2021/08/16 13:32:42 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add support for Horizontal Differencing Predictor. - posted by de...@apache.org on 2021/08/16 17:08:04 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Refactor: - Move inflater in a new "...storage.inflater" package for sharing with other raster formats in the future. - Add a hock for releasing native resource potentially held by `Inflater` (e.g. for a ZIP inflater). - Reuse the same `Inflater` instance for all tiles to read in a single call to `read(…)`. - Verifies `HorizontalPredictor` assumption (currently works only with bytes). - Consolidation: add comments, rename some variables, rename some classes. - posted by de...@apache.org on 2021/08/17 17:32:06 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Continue to parse unit even if the date can not be parsed. For example the unit is sometime "hours since analysis" instead of "hours since 1970-01-01 00:00:00". - posted by de...@apache.org on 2021/08/17 22:25:03 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (5024fa9 -> 0fe01ad) - posted by de...@apache.org on 2021/08/27 17:20:55 UTC, 0 replies.
- [sis] 01/11: Provides `SQLBuilder` configuration in a separated class (`Syntax`) for making possible to reuse configuration analysis. Add methods in `SQLBuilder` for pagination and for distinct values. - posted by de...@apache.org on 2021/08/27 17:20:56 UTC, 0 replies.
- [sis] 02/11: Move the handling of `ReferenceSystem` outside `SQLBuilder`. - posted by de...@apache.org on 2021/08/27 17:20:57 UTC, 0 replies.
- [sis] 03/11: Add a copy constructor. Document the issue about parameterized type in `Visitor.visit(…)` methods. - posted by de...@apache.org on 2021/08/27 17:20:58 UTC, 0 replies.
- [sis] 04/11: Add a method for getting filters as a `F₀ AND F₁ AND F₂ AND F₃ AND ...` sequence. It allows to translate some Fₙ to SQL statements without forcing an "all or nothing" policy. - posted by de...@apache.org on 2021/08/27 17:20:59 UTC, 0 replies.
- [sis] 05/11: Give public access to the `SortProperty` elements wrapped by `SortByComparator`. It allows `DataStore` implementations to translate "sort by" into SQL statements. - posted by de...@apache.org on 2021/08/27 17:21:00 UTC, 0 replies.
- [sis] 06/11: Provide `String` constants for predefined attribute names. It avoid synchronization on `GenericName.toString()` calls. - posted by de...@apache.org on 2021/08/27 17:21:01 UTC, 0 replies.
- [sis] 07/11: Better `toString()` (for debugging only) of the query executed by `FeatureSubset`. Give to `Stream.filter(Predicate)` the filter directly, not a lambda to the `test` method. This is important for allowing stream implementations to optimize the filters. - posted by de...@apache.org on 2021/08/27 17:21:02 UTC, 0 replies.
- [sis] 08/11: Relax the requirement that the source CRS is non-null in a call to `transform(targetCRS)`. A null sourceCRS will be a no-operation. This is consistent with current target CRS policy. This change is for making easier to implement a data store on SQL database such as PostGIS, when the geometry in a filter expression is often specified by a WKT without CRS. - posted by de...@apache.org on 2021/08/27 17:21:03 UTC, 0 replies.
- [sis] 09/11: Add an `Optimization.setFeatureType(…)` method and update some filter/expression implementations for taking advantage of it. - posted by de...@apache.org on 2021/08/27 17:21:04 UTC, 0 replies.
- [sis] 10/11: Refactoring of `sis-sqlstorage` module: - Make import closer to the order on other branch. This is not necessarily a better order, but the intend is to reduce conflicts at merge time. - Merge `SQLBiFunction` and `ColumnAdapter` into a single abstract class: `ValueGetter`. - Merge `SQLColumn`, `ColumnRef` and `GeometryColumn` in a single `Column` class. - Merge `DialectMapping` and `ANSIMapping` in a single `Session` class. - Delegate WKB parsing to the geometry library (JTS, ESRI…). - Re [...] - posted by de...@apache.org on 2021/08/27 17:21:05 UTC, 0 replies.
- [sis] 11/11: Remove (for now) JMH dependencies because not used anymore. We will revert this commit in the future if JMH is used again. - posted by de...@apache.org on 2021/08/27 17:21:06 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (0fe01ad -> bd56303) - posted by de...@apache.org on 2021/08/31 17:25:15 UTC, 0 replies.
- [sis] 01/07: Add performance tips about the use of filters. - posted by de...@apache.org on 2021/08/31 17:25:16 UTC, 0 replies.
- [sis] 02/07: USe `X_DIMENSION` and `Y_DIMENSION` constants for 0 and 1. Fix a tile width which was sometime wrong (a `forceTileSize` flag has been added). - posted by de...@apache.org on 2021/08/31 17:25:17 UTC, 0 replies.
- [sis] 03/07: Faster transfer of sample values from `input.buffer` to the image `bank`. - posted by de...@apache.org on 2021/08/31 17:25:18 UTC, 0 replies.
- [sis] 04/07: Apply the Horizontal Differencing predictor on other data types than bytes. - posted by de...@apache.org on 2021/08/31 17:25:19 UTC, 0 replies.
- [sis] 05/07: Fix a NullPointerException. - posted by de...@apache.org on 2021/08/31 17:25:20 UTC, 0 replies.
- [sis] 06/07: Remove a warning about unused GeogCitation key. - posted by de...@apache.org on 2021/08/31 17:25:21 UTC, 0 replies.
- [sis] 07/07: Parse some more metadata from Landsat. - posted by de...@apache.org on 2021/08/31 17:25:22 UTC, 0 replies.