You are viewing a plain text version of this content. The canonical link for it is here.
- [sis] branch geoapi-4.0 updated (df7e1fb -> 4fe1348) - posted by de...@apache.org on 2020/11/03 22:54:51 UTC, 0 replies.
- [sis] 01/04: Paranoiac check in case the attribute value is already a list. - posted by de...@apache.org on 2020/11/03 22:54:52 UTC, 0 replies.
- [sis] 02/04: Place-holder for JDK 9 methods should have the same behavior than JDK 9, which is to throw IllegalArgumentException if there is duplicated values. - posted by de...@apache.org on 2020/11/03 22:54:53 UTC, 0 replies.
- [sis] 03/04: Documentation and formatting related to WKT parsing. Deprecate Symbols.containsAxis(…) because AXIS elements are no longer optional in WKT 2. - posted by de...@apache.org on 2020/11/03 22:54:54 UTC, 0 replies.
- [sis] 04/04: Rename the `list` field as `children` and make the code more null-safe by replacing the null value by a more explicit `isEnumeration` flag. - posted by de...@apache.org on 2020/11/03 22:54:55 UTC, 0 replies.
- [jira] [Created] (SIS-502) Allow users to define CRS for custom codes - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/05 09:15:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (4fe1348 -> 5e13b7f) - posted by de...@apache.org on 2020/11/09 23:16:11 UTC, 0 replies.
- [sis] 01/03: Clarify the behavior of `WKTFormat.clone()` and avoid cloning the `fragments` map if possible. The intent is to allow more efficient `WKTFormat` cloning for parsing many WKT strings in parallel. - posted by de...@apache.org on 2020/11/09 23:16:12 UTC, 0 replies.
- [sis] 02/03: Clarify which locale is used in error messages. - posted by de...@apache.org on 2020/11/09 23:16:13 UTC, 0 replies.
- [sis] 03/03: Initial version of `WKTDictionary` for allowing users to define CRS for custom codes. https://issues.apache.org/jira/browse/SIS-502 - posted by de...@apache.org on 2020/11/09 23:16:14 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Allow `getAuthorityCodes(Class)` to filter by WKT keywords. Build the code list under write lock. Cache results. - posted by de...@apache.org on 2020/11/11 16:06:47 UTC, 0 replies.
- [jira] [Created] (SIS-503) Naming issue in setters of DefaultReleasability - posted by "jean-marc Bourdaret (Jira)" <ji...@apache.org> on 2020/11/17 15:59:00 UTC, 0 replies.
- [jira] [Assigned] (SIS-503) Naming issue in setters of DefaultReleasability - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/17 18:14:00 UTC, 0 replies.
- [jira] [Commented] (SIS-503) Naming issue in setters of DefaultReleasability - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/17 18:14:00 UTC, 0 replies.
- [jira] [Updated] (SIS-503) Naming issue in setters of DefaultReleasability - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/17 18:14:00 UTC, 1 replies.
- [sis] branch geoapi-4.0 updated: Refactor the way we store WKT trees in a dictionary. Instead of having `Element` working in two modes (mutable or immutable), keep `Element` always mutable and create immutable snapshots with a separated class, `StoredTree`. - posted by de...@apache.org on 2020/11/17 23:39:38 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add tests and fix missed sharing of WKT values. - posted by de...@apache.org on 2020/11/18 16:03:11 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (31a6086 -> 85cfff7) - posted by de...@apache.org on 2020/11/18 23:52:16 UTC, 0 replies.
- [sis] 01/03: Move `getAuthoritycodes(Class)` close to `getCodeSpaces(). This is a cut-and-paste with no code change. - posted by de...@apache.org on 2020/11/18 23:52:17 UTC, 0 replies.
- [sis] 02/03: Add more tests. - posted by de...@apache.org on 2020/11/18 23:52:18 UTC, 0 replies.
- [sis] 03/03: Handle the corner-case of coordinate system WKT (the "CS" keyword) in definition of aliases. - posted by de...@apache.org on 2020/11/18 23:52:19 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (85cfff7 -> a1ab9bb) - posted by de...@apache.org on 2020/11/19 13:32:08 UTC, 0 replies.
- [sis] 01/02: Log warnings during WKT parsing by `WKTDictionary`. - posted by de...@apache.org on 2020/11/19 13:32:09 UTC, 0 replies.
- [sis] 02/02: Update examples of ESRI codes. - posted by de...@apache.org on 2020/11/19 13:32:10 UTC, 0 replies.
- [jira] [Resolved] (SIS-502) Allow users to define CRS for custom codes - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/19 22:14:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Method name change: setter method shall have the "set" prefix, not "get". Error identified by Jean-Marc Bourdaret. https://issues.apache.org/jira/browse/SIS-503 - posted by de...@apache.org on 2020/11/19 22:26:36 UTC, 0 replies.
- [jira] [Resolved] (SIS-503) Naming issue in setters of DefaultReleasability - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/19 22:27:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (d478c79 -> 81a9536) - posted by de...@apache.org on 2020/11/21 21:58:43 UTC, 0 replies.
- [sis] 01/02: Replace `String.regionMatches(…)` by the simpler `String.startsWith(…)` when applicable. - posted by de...@apache.org on 2020/11/21 21:58:44 UTC, 0 replies.
- [sis] 02/02: Provides a hook for making easier to use this factory for handling the "spatial_ref_sys" table of spatial databases. - posted by de...@apache.org on 2020/11/21 21:58:45 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Automatically add identifier when the WKT provided by `WKTDictionary.fetchDefinition(…)` does not contain an ID[…] or AUTHORITY[…] element. This is needed when the WKT is provided by the "spatial_ref_sys" table if a PostGIS spatial database among others. - posted by de...@apache.org on 2020/11/22 12:57:36 UTC, 0 replies.
- [jira] [Created] (SIS-504) Simplify the logging levels defined in PerformanceLevel - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/23 13:58:00 UTC, 0 replies.
- [jira] [Updated] (SIS-504) Simplify the logging levels defined in PerformanceLevel - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/24 10:29:00 UTC, 2 replies.
- [sis] branch geoapi-4.0 updated (89f8591 -> 925eccf) - posted by de...@apache.org on 2020/11/24 22:25:13 UTC, 0 replies.
- [sis] 01/03: Simplify the logging levels provided by `PerformanceLevel`. https://issues.apache.org/jira/browse/SIS-504 - posted by de...@apache.org on 2020/11/24 22:25:14 UTC, 0 replies.
- [sis] 02/03: Replace a few `getLogger("org.apache.sis.foo")` calls by a static `Logger` constant. Use the logger provided by `DataStoreProvider.getLogger()` when applicable. Add a log when reading a netCDF file as a `GridCoverage`. - posted by de...@apache.org on 2020/11/24 22:25:15 UTC, 0 replies.
- [sis] 03/03: Reduce a little bit the amount of text in `GridGeometry.toString()` and in `AbstractGridResource.logLoadOperation(…)`. - posted by de...@apache.org on 2020/11/24 22:25:16 UTC, 0 replies.
- [jira] [Resolved] (SIS-504) Simplify the logging levels defined in PerformanceLevel - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/11/24 22:26:00 UTC, 0 replies.
- Inbox (4) | New Cloud Notification - posted by "CLOUD-SIS.APACHE.ORG" <no...@SIS.APACHE.ORG> on 2020/11/25 11:29:53 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Provide a way to avoid potentially costly PropertyNotFoundException creation. Users do not always know in advance if a property exists and may need a way to get this information without being forced to use exceptions for branching. - posted by de...@apache.org on 2020/11/25 23:08:37 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Rename `getPropertyValue(String, Object)` as `getValueOrFallback(…)` for avoiding dangerous similarity with `setPropertyValue(…)`. Before this change, the two methods differed only by one letter ("g" versus "s"), which is a risk of introducing bugs by typos. The new name is also more readable and more consistent with standard Java practice such as `java.util.Map.getOrDefault(…)`. - posted by de...@apache.org on 2020/11/26 11:50:04 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (c0bf843 -> da00b49) - posted by de...@apache.org on 2020/11/30 17:17:15 UTC, 0 replies.
- [sis] 01/03: Avoid duplication in netCDF variables and attributes when a lower-case name has been generated in addition to the original name. - posted by de...@apache.org on 2020/11/30 17:17:16 UTC, 0 replies.
- [sis] 02/03: More robust handling of map projection parameters in netCDF file: - If parameters are provided as strings instead than numbers, parse them. - Report unused values for allowing user to check if an important parameter has been ignored. - posted by de...@apache.org on 2020/11/30 17:17:17 UTC, 0 replies.
- [sis] 03/03: Always consider a variable as an axis if the "_CoordinateAxisType" attribute is present. - posted by de...@apache.org on 2020/11/30 17:17:18 UTC, 0 replies.