You are viewing a plain text version of this content. The canonical link for it is here.
- [sis] branch geoapi-4.0 updated (5ad04a9 -> 4de677a) - posted by de...@apache.org on 2020/08/03 17:26:51 UTC, 0 replies.
- [sis] 01/04: Fix an ineffective verification. - posted by de...@apache.org on 2020/08/03 17:26:52 UTC, 0 replies.
- [sis] 02/04: Make `PixelIterator.getSampleRange()` method implementation more generic (no more test for specific `SampleModel` subclasses). - posted by de...@apache.org on 2020/08/03 17:26:53 UTC, 0 replies.
- [sis] 03/04: ResampleImage computes itself the ranges of values instead than invoking `PixelIterator.getSampleRanges()`, because that later method returns ranges of source pixel values while we need ranges of target pixel values. - posted by de...@apache.org on 2020/08/03 17:26:54 UTC, 0 replies.
- [sis] 04/04: Make `resample` more robust to cases where target data type is not the same than source data type. In particular in the way to compute min/max values and to determine if a shortcut can be used. - posted by de...@apache.org on 2020/08/03 17:26:55 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: First draft of a `Visualization` image which combine the work of "resample" and "visualize" methods. The intent is to avoid to create an intermediate image when a resampling is done only for visualization. - posted by de...@apache.org on 2020/08/04 18:07:26 UTC, 0 replies.
- [jira] [Created] (SIS-498) Replace PassthroughTransform by CompoundTransform - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/08/04 22:00:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Stretch color ramp (if requested) before to resample the image, for simplifying `CoverageCanvas` a little bit. This is an apparent waste of CPU time because the resample operation should not need to be redone when only the ColorModel has changed, but `ImageProcessor` is capable to detect and optimize this case by itself. - posted by de...@apache.org on 2020/08/04 23:03:48 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (294b39e -> e37076c) - posted by de...@apache.org on 2020/08/05 20:32:39 UTC, 0 replies.
- [sis] 01/02: Add a safety check against integer overflow, trace information for debugging and link to JIRA task. - posted by de...@apache.org on 2020/08/05 20:32:40 UTC, 0 replies.
- [sis] 02/02: Enable the use of IndexColorModel in CoverageCanvas. - posted by de...@apache.org on 2020/08/05 20:32:41 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Provide a RenderingMode.DIRECT which avoid creation of a double buffer as the cost of executing `paint(Graphics2D)` in the JavaFX thread. It is okay if that method does only a `Graphics2D.drawRenderedImage(…)` call without scale or rotation, in which case we are not blocking the JavaFX thread longer than in the RenderingMode.DOUBLE_BUFFERED case. - posted by de...@apache.org on 2020/08/06 14:33:28 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Fix a NullPointerException when transforming coordinates with SpecializableTransform.transform(…) methods working on arrays and the last coordinates are inside a sub-grid. - posted by de...@apache.org on 2020/08/06 17:23:37 UTC, 0 replies.
- [sis] branch master updated: Fix a NullPointerException when transforming coordinates with SpecializableTransform.transform(…) methods working on arrays and the last coordinates are inside a sub-grid. (Cherry-pick from d92bcd3d94d6ebcd54d7703a41785b5bdef7023a) - posted by de...@apache.org on 2020/08/06 17:29:01 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Remove ImageUtilities.getDataType(…) methods, replaced by getBandType(SampleModel). The previous method was returning the storage type, which can be misleading when the 4 bytes values of an ARGB image are packed in a single 32-bits integer value (java.awt.image.SinglePixelPackedSampleModel and MultiPixelPackedSampleModel). In practice, the type usually wanted by SIS is the type that the image would have if it was using a java.awt.image.BandedSampleModel. - posted by de...@apache.org on 2020/08/07 17:19:32 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Rename CategoryCellFactory as BandRangeTable. - posted by de...@apache.org on 2020/08/08 22:18:33 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (8d5386a -> 1d075eb) - posted by de...@apache.org on 2020/08/11 18:34:04 UTC, 0 replies.
- [sis] 01/02: Add a missing `class="sis"` attributes in `` HTML elements. - posted by de...@apache.org on 2020/08/11 18:34:05 UTC, 0 replies.
- [sis] 02/02: Provide control on the colors used for rendering different range of values (categories) of a GridCoverage. - posted by de...@apache.org on 2020/08/11 18:34:06 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (1d075eb -> 39ec26d) - posted by de...@apache.org on 2020/08/12 17:32:55 UTC, 0 replies.
- [sis] 01/04: Minor adjustments: make colors column not sortable, documentation, NetBeans configuration. - posted by de...@apache.org on 2020/08/12 17:32:56 UTC, 0 replies.
- [sis] 02/04: Fix a NullPointerException. - posted by de...@apache.org on 2020/08/12 17:32:57 UTC, 0 replies.
- [sis] 03/04: Avoid to declare provided on netCDF in section, because it causes difficulties to control the scope in transitive dependencies. Instead all uses of netCDF in sub-modules must declare the desired scope explicitly. - posted by de...@apache.org on 2020/08/12 17:32:58 UTC, 0 replies.
- [sis] 04/04: Prepare packaging of JavaFX application. - posted by de...@apache.org on 2020/08/12 17:32:59 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (39ec26d -> 2bc3e93) - posted by de...@apache.org on 2020/08/12 23:56:12 UTC, 0 replies.
- [sis] 01/04: Omit the navigation bar in javadoc.jar files deployed by Maven, because those javadoc are typically browsed from browser. This is a first attempt to avoid the inclusion of GPL code in javadoc (introduced by the search field in navigation bar). This change does not apply to aggregated javadoc, and is not yet sufficient for avoiding the GPL code anyway. - posted by de...@apache.org on 2020/08/12 23:56:13 UTC, 0 replies.
- [sis] 02/04: Add a temporary dummy class for allowing javadoc to pass. This is because javadoc requires to have at least one class to document. - posted by de...@apache.org on 2020/08/12 23:56:14 UTC, 0 replies.
- [sis] 03/04: Fix javadoc generation errors. - posted by de...@apache.org on 2020/08/12 23:56:15 UTC, 0 replies.
- [sis] 04/04: Add EPSG database if explicitly requested by profile. - posted by de...@apache.org on 2020/08/12 23:56:16 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (2bc3e93 -> 42b1726) - posted by de...@apache.org on 2020/08/13 23:59:29 UTC, 0 replies.
- [sis] 01/03: Add a splash screen. Fix destination directory of log file. - posted by de...@apache.org on 2020/08/13 23:59:30 UTC, 0 replies.
- [sis] 02/03: Ask user to specify JavaFX installation directory on the first execution. - posted by de...@apache.org on 2020/08/13 23:59:31 UTC, 0 replies.
- [sis] 03/03: Initial Windows batch script for launching the application. - posted by de...@apache.org on 2020/08/13 23:59:32 UTC, 0 replies.
- [jira] [Created] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Roland (Jira)" <ji...@apache.org> on 2020/08/14 08:15:00 UTC, 0 replies.
- [jira] [Assigned] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/08/14 09:30:00 UTC, 0 replies.
- [jira] [Commented] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/08/14 09:55:00 UTC, 16 replies.
- [jira] [Comment Edited] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Roland (Jira)" <ji...@apache.org> on 2020/08/14 10:56:00 UTC, 0 replies.
- [jira] [Issue Comment Deleted] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Roland (Jira)" <ji...@apache.org> on 2020/08/14 10:59:00 UTC, 0 replies.
- [jira] [Updated] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Roland (Jira)" <ji...@apache.org> on 2020/08/14 11:01:00 UTC, 2 replies.
- [sis] branch geoapi-4.0 updated (42b1726 -> 906b2a1) - posted by de...@apache.org on 2020/08/15 12:15:41 UTC, 0 replies.
- [sis] 01/02: Declare static final constants for programmatic names such as directory and environment variable. - posted by de...@apache.org on 2020/08/15 12:15:42 UTC, 0 replies.
- [sis] 02/02: Change the URL to Jenkins server. - posted by de...@apache.org on 2020/08/15 12:15:43 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (906b2a1 -> 58e66f5) - posted by de...@apache.org on 2020/08/17 18:18:50 UTC, 0 replies.
- [sis] 01/03: Add a "Close" menu item in the main "File" menu. It previously existed only in the contextual menu, which was non-obvious. - posted by de...@apache.org on 2020/08/17 18:18:51 UTC, 0 replies.
- [sis] 02/03: Fix an mismatched dimension errors when the source CRS has more dimensions than the core transform. - posted by de...@apache.org on 2020/08/17 18:18:52 UTC, 0 replies.
- [sis] 03/03: Avoid direct use of a word which become a keyword in latest Java versions. - posted by de...@apache.org on 2020/08/17 18:18:53 UTC, 0 replies.
- [jira] [Resolved] (SIS-499) CommonCRS.WGS84.geographic() fails to initialize with JDK 11.0.8 - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/08/18 08:21:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (58e66f5 -> e6cffdb) - posted by de...@apache.org on 2020/08/19 10:36:16 UTC, 0 replies.
- [sis] 01/03: Enable change of input method in text editors. - posted by de...@apache.org on 2020/08/19 10:36:17 UTC, 0 replies.
- [sis] 02/03: Provides a convenience method for getting a single `GeographicBoundingBox` from a `Metadata`. - posted by de...@apache.org on 2020/08/19 10:36:18 UTC, 0 replies.
- [sis] 03/03: Add a ModifiableMetadata.deepCopy(…) method. - posted by de...@apache.org on 2020/08/19 10:36:19 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (e6cffdb -> 4363b5d) - posted by de...@apache.org on 2020/08/19 17:38:33 UTC, 0 replies.
- [sis] 01/02: Add a DefaultMetadata.deepCopy(Metadata) convenience method. For now we add that convenience method only for the root Metadata object because it is the kind of objects returned by DataStore.getMetadata() methods. - posted by de...@apache.org on 2020/08/19 17:38:34 UTC, 0 replies.
- [sis] 02/02: Documentation for clarifying the use of properties versus method parameters. - posted by de...@apache.org on 2020/08/19 17:38:35 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: First version of ImageCombiner. - posted by de...@apache.org on 2020/08/20 18:19:37 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (6ff9dd1 -> 5339509) - posted by de...@apache.org on 2020/08/21 11:01:35 UTC, 0 replies.
- [sis] 01/02: Fix a few holes related to the addition of a `destination` property in `ComputedImage`. - posted by de...@apache.org on 2020/08/21 11:01:36 UTC, 0 replies.
- [sis] 02/02: Do not overwrite puxels in destination image that are not covered by a pixel in source image. - posted by de...@apache.org on 2020/08/21 11:01:37 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (5339509 -> 396816f) - posted by de...@apache.org on 2020/08/21 18:05:18 UTC, 0 replies.
- [sis] 01/03: Replace the `PreferredSize` hack by a public API. - posted by de...@apache.org on 2020/08/21 18:05:19 UTC, 0 replies.
- [sis] 02/03: Rename `ImageProcessor.getStatistics(…)` as `valueOfStatistics(…)`. The intent is to make a clearer separation with property getter methods. It also reduces the impression that this method returns a pre-existing value (the computation can be expansive). - posted by de...@apache.org on 2020/08/21 18:05:20 UTC, 0 replies.
- [sis] 03/03: Hide the splash screen after application startup. - posted by de...@apache.org on 2020/08/21 18:05:21 UTC, 0 replies.
- [jira] [Created] (SIS-500) Deprecate (for removal) InterpolatedMolodenskyTransform - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/08/22 08:39:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (396816f -> 9c19789) - posted by de...@apache.org on 2020/08/26 12:59:57 UTC, 0 replies.
- [sis] 01/03: Clarification in comment. - posted by de...@apache.org on 2020/08/26 12:59:58 UTC, 0 replies.
- [sis] 02/03: Note that BufferedImage.getTileGridOffset() bug (JDK-8166038) has been fixed in JDK 16. - posted by de...@apache.org on 2020/08/26 12:59:59 UTC, 0 replies.
- [sis] 03/03: When computing the `gridToCRS` of target grid geometry, avoid putting two values in the same column and leaving another column with only zero value, as it makes the matrix non-invertible. - posted by de...@apache.org on 2020/08/26 13:00:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (9c19789 -> 88f8361) - posted by de...@apache.org on 2020/08/26 14:50:24 UTC, 0 replies.
- [sis] 01/02: Trivial indentation fix. - posted by de...@apache.org on 2020/08/26 14:50:25 UTC, 0 replies.
- [sis] 02/02: Move Variable.Adjustment as a separated GridAdjustment class. Modify the way to apply a scale on the GridGeometry in order to control the MathTransform ("corner to CRS" or "center to CRS") on which the scale is applied. - posted by de...@apache.org on 2020/08/26 14:50:26 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: After invocation of ImageUtilities.clip(…), verifiy that the intersection is not empty. Various documentation fixes. - posted by de...@apache.org on 2020/08/27 17:10:12 UTC, 0 replies.
- [sis] branch feat/sourceDomainExpansion created (now 6e8b8eb) - posted by js...@apache.org on 2020/08/31 15:22:45 UTC, 0 replies.
- [sis] 01/01: Best effort implementation of coverage query source domain expansion parameter - posted by js...@apache.org on 2020/08/31 15:22:46 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (3771a28 -> 5227d01) - posted by de...@apache.org on 2020/08/31 17:35:44 UTC, 0 replies.
- [sis] 01/02: When there is no direct Bursa-Wolf parameters between two CRS, accepts an indirect transformation through a common hub (typically WGS 84). This is a partial revert of commit 504e3ce3bfd44c6aea1ff9f4d5ba298d4b0a22f2 (November 14, 2013) together with new code for updating positional accuracy. An arbitrary value of 100 metres is taken when the domains of validity intersect, and 3000 metres (presumed worst case scenario) otherwise. - posted by de...@apache.org on 2020/08/31 17:35:45 UTC, 0 replies.
- [sis] 02/02: Add a WraparoundTransform, to be used in a next commit for resampling images crossing the anti-meridian. - posted by de...@apache.org on 2020/08/31 17:35:46 UTC, 0 replies.
- [sis] branch master updated: When there is no direct Bursa-Wolf parameters between two CRS, accepts an indirect transformation through a common hub (typically WGS 84). This is a cherry-pick from afdf695c15841e6f6d2ad23c24833111b4d0331e. - posted by de...@apache.org on 2020/08/31 18:06:42 UTC, 0 replies.