You are viewing a plain text version of this content. The canonical link for it is here.
- [sis] branch geoapi-4.0 updated: Dialect : add SQLite dialect in enumeration - posted by js...@apache.org on 2020/06/01 10:15:14 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Dialect : improve support for sqlite, ignore statements with table constraint modifications - posted by js...@apache.org on 2020/06/01 13:01:08 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (d532cb5 -> a9ecd8b) - posted by de...@apache.org on 2020/06/02 11:03:19 UTC, 0 replies.
- [sis] 01/02: Rename older Dialect fields for consistency. Refine regular expression. - posted by de...@apache.org on 2020/06/02 11:03:20 UTC, 0 replies.
- [sis] 02/02: Change EnvelopeOperation.serialVersionUID since the meaning of null values in `attributeToCRS` changed. Since we broke serialization compatibility anyway, opportunistically rename `crs` as `targetCRS` for making clearer that this is not necessarily the CRS of geometry objects stored in properties. - posted by de...@apache.org on 2020/06/02 11:03:21 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add ImageProcessor.setPositionalAccuracyHints(…) method for enabling the use of ResamplingGrid. - posted by de...@apache.org on 2020/06/02 16:45:09 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add a GridRoundingMode.CONTAINED for completness. - posted by de...@apache.org on 2020/06/02 22:17:19 UTC, 0 replies.
- [sis] branch feat/resample deleted (was d107907) - posted by de...@apache.org on 2020/06/03 10:04:21 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: chore(Storage): add unit test to check concurrency of DataStores providers fetching - posted by am...@apache.org on 2020/06/03 16:44:17 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (3291366 -> d380dff) - posted by de...@apache.org on 2020/06/03 21:36:25 UTC, 0 replies.
- [sis] 01/02: Complete parameterized types in collections. Add documentation. Use longer timeout as a safety in case the test is executed on a busy CI system (this is only a maximal wait; the actual waiting time should be much shorter). IF the executor is not terminated after the test, it is a test failure because it would be a bug in our algorithm (because we already waited in Future.get()). - posted by de...@apache.org on 2020/06/03 21:36:26 UTC, 0 replies.
- [sis] 02/02: Add a setPositionalAccuracyHints(Quantity...) convenience method. - posted by de...@apache.org on 2020/06/03 21:36:27 UTC, 0 replies.
- [jira] [Created] (SIS-495) Resampling trims one pixel when transform is identity and interpolation is nearest - posted by "Johann Sorel (Jira)" <ji...@apache.org> on 2020/06/04 07:37:00 UTC, 0 replies.
- [jira] [Updated] (SIS-495) Resampling trims one pixel when transform is identity and interpolation is nearest - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/04 08:04:00 UTC, 1 replies.
- [sis] branch geoapi-4.0 updated: fix(Core): fix bad size computing on GridCoverage2D render (crop) operation - posted by am...@apache.org on 2020/06/04 10:15:41 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add integer overflow analysis in GridCoverage2D.render(…) method for BufferedImage case. Detect when existing BufferedImage can be returned as-is instead of invoking `getSubImage`. Add test case for https://issues.apache.org/jira/browse/SIS-495 - posted by de...@apache.org on 2020/06/04 12:11:45 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Bug fix: test for minimal coordinates shall be done on the extent specified by user (xmin, ymin), not on (ix, iy). - posted by de...@apache.org on 2020/06/04 12:23:55 UTC, 0 replies.
- [jira] [Resolved] (SIS-495) Resampling trims one pixel when transform is identity and interpolation is nearest - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/04 12:59:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: GridCoverage2D.render(GridExtent) should verify the number of dimension of given extent, for consistency with other GridCoverage.render(GridExtent) implementations. - posted by de...@apache.org on 2020/06/04 13:01:33 UTC, 0 replies.
- svn commit: r1878522 - in /sis/analysis: Modified Azimuthal Equidistant.wxmx README.html - posted by de...@apache.org on 2020/06/05 15:29:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (a9cf30c -> 6ec7408) - posted by de...@apache.org on 2020/06/05 17:00:52 UTC, 0 replies.
- [sis] 01/02: Fix an incorrect computation of image (minX, minY) coordinates when the `sliceExtent` has some pixels outside the image bounds. Allow `ImageRenderer` to use an implementation other than `BufferedImage` when the (minX, minY) are different than (0, 0). - posted by de...@apache.org on 2020/06/05 17:00:53 UTC, 0 replies.
- [sis] 02/02: Add NumberRange.getMedian() and getSpan() methods. - posted by de...@apache.org on 2020/06/05 17:00:54 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Show the coverage value under mouse cursor position. - posted by de...@apache.org on 2020/06/08 17:22:10 UTC, 0 replies.
- [jira] [Assigned] (SIS-485) Replace GridCoverage.evaluate(DirectPosition, …) method - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/09 13:00:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (03392c5 -> 2c3e3be) - posted by de...@apache.org on 2020/06/09 17:38:04 UTC, 0 replies.
- [sis] 01/04: Abandon the possibility to change the `MapCanvas` of a `StatusBar` after status bar creation. That capability was adding complexity (i.e. tracking the listeners to unregister on previous canvas and re-register on new canvas). The capability to change StatusBar canvas does not seem to be needed in practice. - posted by de...@apache.org on 2020/06/09 17:38:05 UTC, 0 replies.
- [sis] 02/04: Better calculation of label width needed for showing sample values. - posted by de...@apache.org on 2020/06/09 17:38:06 UTC, 0 replies.
- [sis] 03/04: Remove a hack which was not needed. A simple use of `Label.USE_PREF_SIZE` does the trick. - posted by de...@apache.org on 2020/06/09 17:38:07 UTC, 0 replies.
- [sis] 04/04: Remove GridCoverage.evaluate(…) method, replaced by an `Evaluator` class. This commit is only a refactoring without changes in functionalities. Future commits will add more capabilities or optimizations. - posted by de...@apache.org on 2020/06/09 17:38:08 UTC, 0 replies.
- [jira] [Resolved] (SIS-485) Replace GridCoverage.evaluate(DirectPosition, …) method - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/09 17:52:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (2c3e3be -> 682573b) - posted by de...@apache.org on 2020/06/10 16:01:03 UTC, 0 replies.
- [sis] 01/03: Add a flag for reducing the amount of exceptions created when a point is outside coverage bounds. - posted by de...@apache.org on 2020/06/10 16:01:04 UTC, 0 replies.
- [sis] 02/03: Move `BufferedGridCoverage` in public API. - posted by de...@apache.org on 2020/06/10 16:01:05 UTC, 0 replies.
- [sis] 03/03: More efficient implementation of `BufferedGridCoverage.evaluator()`. - posted by de...@apache.org on 2020/06/10 16:01:06 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: First draft of an image providing error estimations for each pixel of a resampled image. - posted by de...@apache.org on 2020/06/10 17:34:34 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Provide a new "Operations" panel in `CoverageControls` with possibility to select the "Positional errors" for current coverage. Use weak reference for the image of positional errors. - posted by de...@apache.org on 2020/06/11 16:51:43 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Display values of "positional errors" operation on status bar. - posted by de...@apache.org on 2020/06/13 16:16:06 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Filter : implement PropertyIsLike filter - posted by js...@apache.org on 2020/06/15 10:29:27 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: SQLStore : accept a DataStore instead of SQLStore in Database methods - posted by js...@apache.org on 2020/06/15 12:29:57 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (e86d55d -> 0265dc6) - posted by de...@apache.org on 2020/06/15 17:31:06 UTC, 0 replies.
- [sis] 01/05: Modify `StatusBarSupport` for avoiding a memory leak (reference to image that are not shown anymore). Remove "Positional errors" from the list of operations when it does not apply. - posted by de...@apache.org on 2020/06/15 17:31:07 UTC, 0 replies.
- [sis] 02/05: Specify an area of interest when computing statistics. - posted by de...@apache.org on 2020/06/15 17:31:08 UTC, 0 replies.
- [sis] 03/05: Change argument order in `ImageProcessor.resample(…)`. No change in functionality. - posted by de...@apache.org on 2020/06/15 17:31:09 UTC, 0 replies.
- [sis] 04/05: Change `StatusBar(…)` argument order and prepare for tracking more than one canvas in a future version. - posted by de...@apache.org on 2020/06/15 17:31:10 UTC, 0 replies.
- [sis] 05/05: Take axis directions in account when computing the initial "objective to CRS". This change fixes the image flipping. - posted by de...@apache.org on 2020/06/15 17:31:11 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Change of projection in MapCanvas need to use an orthonormal matrix for preserving the projection aspect. - posted by de...@apache.org on 2020/06/16 10:05:16 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Fix an shift observed during change of map projection. The fix require an anchor point to be specified in call to `setObjectiveCRS(…)`. - posted by de...@apache.org on 2020/06/16 13:32:29 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (bba7e3c -> f2c4c23) - posted by de...@apache.org on 2020/06/17 17:39:25 UTC, 0 replies.
- [sis] 01/03: Do not allow the use of display CRS in the definition of Point Of Interest. - posted by de...@apache.org on 2020/06/17 17:39:26 UTC, 0 replies.
- [sis] 02/03: Resolve a duplication in the offered CRS items. - posted by de...@apache.org on 2020/06/17 17:39:27 UTC, 0 replies.
- [sis] 03/03: Fix image transparency. - posted by de...@apache.org on 2020/06/17 17:39:28 UTC, 0 replies.
- [jira] [Created] (SIS-496) GridCoverage.forConvertedValues(true) sometime creates an image that can not store NaN values - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/19 10:37:00 UTC, 0 replies.
- [jira] [Commented] (SIS-496) GridCoverage.forConvertedValues(true) sometime creates an image that can not store NaN values - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/19 10:37:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: GridCoverage.forConvertedValues(true) sometime created an image that can not store NaN values. - posted by de...@apache.org on 2020/06/19 10:39:34 UTC, 0 replies.
- [jira] [Resolved] (SIS-496) GridCoverage.forConvertedValues(true) sometime creates an image that can not store NaN values - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/19 10:41:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Replace the "Image operation" pane by an "Image properties" pane. We are not ready to offer image operations in the JavaFX applications. Instead image sources, layout and properties are more useful information, with the previous "positional errors" operation shown as an image property. - posted by de...@apache.org on 2020/06/22 18:45:32 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (998181d -> 4a35aa0) - posted by de...@apache.org on 2020/06/23 17:57:38 UTC, 0 replies.
- [sis] 01/07: Remove `ValuesUnderCursor.evaluateAtPixel(…)` method. It is not used anymore after previous commit. - posted by de...@apache.org on 2020/06/23 17:57:39 UTC, 0 replies.
- [sis] 02/07: Pass argument lines to Maven surefire for allowing `sis-javafx` tests to execute. - posted by de...@apache.org on 2020/06/23 17:57:40 UTC, 0 replies.
- [sis] 03/07: Cache of `AnnotatedImage` computation results need to take in account the area of interest. - posted by de...@apache.org on 2020/06/23 17:57:41 UTC, 0 replies.
- [sis] 04/07: Use of scientific notation needs to take in account the number of fraction digits that the NumberFormat allows. - posted by de...@apache.org on 2020/06/23 17:57:42 UTC, 0 replies.
- [sis] 05/07: Make lower/upper cases consistent in map keys given to `stretchColorRamp(…)`. - posted by de...@apache.org on 2020/06/23 17:57:43 UTC, 0 replies.
- [sis] 06/07: Renamed "Positional errors" as "Positional consistency". The previous name was misleading because users believed that it was some kind of "absolute" error measurement, while actually we are just applying a forward projection followed by an inverse projection and comparing numbers. - posted by de...@apache.org on 2020/06/23 17:57:44 UTC, 0 replies.
- [sis] 07/07: Fix the `SAMPLE_RESOLUTIONS_KEY` values to `double[]` in the specification, but keep implementation tolerant to any number type. - posted by de...@apache.org on 2020/06/23 17:57:45 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Save an estimation of transformation accuracy in a new `org.apache.sis.PositionalAccuracy` image property. - posted by de...@apache.org on 2020/06/24 14:51:42 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Show positional accuracy of coordinates under cursor using the information provided by `RenderedImage` property. - posted by de...@apache.org on 2020/06/24 22:03:57 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (3489bf2 -> b594b66) - posted by de...@apache.org on 2020/06/25 14:23:21 UTC, 0 replies.
- [sis] 01/03: `CompoundFormat.getFormat(Class)` should choose `Quantity` formatter before `Number` formatter. - posted by de...@apache.org on 2020/06/25 14:23:22 UTC, 0 replies.
- [sis] 02/03: ImageProcessor.statistics(…) method needs to check if cached result is compatible with requested area of interest. - posted by de...@apache.org on 2020/06/25 14:23:23 UTC, 0 replies.
- [sis] 03/03: Workaround for https://bugs.openjdk.java.net/browse/JDK-8166038 If BufferedImage can not be used, fallback on ReshapedImage. - posted by de...@apache.org on 2020/06/25 14:23:24 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (b594b66 -> ad3c144) - posted by de...@apache.org on 2020/06/26 14:53:28 UTC, 0 replies.
- [sis] 01/05: Add a comment about code to update if JDK-8166038 is fixed. - posted by de...@apache.org on 2020/06/26 14:53:29 UTC, 0 replies.
- [sis] 02/05: Rename a few methods for consistency. No change in functionality (except addition of a `DefaultProperty` annotation and an `assert` statement). - posted by de...@apache.org on 2020/06/26 14:53:30 UTC, 0 replies.
- [sis] 03/05: Simplify the layout of source images in the "Properties" pane. - posted by de...@apache.org on 2020/06/26 14:53:31 UTC, 0 replies.
- [sis] 04/05: Move the menu about band selection first and add a comment about whether positional accuracy are shown. - posted by de...@apache.org on 2020/06/26 14:53:32 UTC, 0 replies.
- [sis] 05/05: Adjust units of measurement for avoiding confusing behavior when coordinate values are shown with units smaller than accuracy. - posted by de...@apache.org on 2020/06/26 14:53:33 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add more tests. - posted by de...@apache.org on 2020/06/26 18:08:25 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add a PlanarImage.MASK_KEY property providing a mask over missing values. - posted by de...@apache.org on 2020/06/27 12:54:49 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (acea035 -> a06af72) - posted by de...@apache.org on 2020/06/29 17:31:16 UTC, 0 replies.
- [sis] 01/06: Clarify MASK_KEY value with multi-banded images. - posted by de...@apache.org on 2020/06/29 17:31:17 UTC, 0 replies.
- [sis] 02/06: Apply mask on the image of positional errors. - posted by de...@apache.org on 2020/06/29 17:31:18 UTC, 0 replies.
- [sis] 03/06: Select map projection through contextual menu instead than combo box. The intent is to allow (in a future commut) creation of map projections centered on a point of interest. - posted by de...@apache.org on 2020/06/29 17:31:19 UTC, 0 replies.
- [sis] 04/06: Simplify a bit the layout of coverage controls. This provides a visual easier to read. - posted by de...@apache.org on 2020/06/29 17:31:20 UTC, 0 replies.
- [sis] 05/06: Provide Azimuthal Equidistant projections centered on arbitrary location. - posted by de...@apache.org on 2020/06/29 17:31:21 UTC, 0 replies.
- [sis] 06/06: Temporarily enable the use of `ResamplingGrid` for testing purpose. Unconditional enabling of this optimization can actually slow down the rendering of zoomed image because the grid is computed for the full image instead than only the visible portion. A future version should enable this optimization only when we know that most of the image surface will be used. - posted by de...@apache.org on 2020/06/29 17:31:22 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Avoid a NaN in AzimuthalEquidistant when (x, y) coordinates are very close to (0, 0). Fix an error in ResampledImage.getPositionalConsistency() that prevented us from visualizing the ResamplingGrid errors. - posted by de...@apache.org on 2020/06/30 10:02:42 UTC, 0 replies.
- [jira] [Resolved] (SIS-493) Raster reprojection - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/30 10:19:00 UTC, 0 replies.
- [jira] [Created] (SIS-497) ResamplingGrid should be incremental - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/30 10:36:00 UTC, 0 replies.
- [jira] [Updated] (SIS-497) ResamplingGrid should be incremental - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/30 10:38:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Comment out for now an optimization which is actually degrading performances in the context of a JavaFX viewer. https://issues.apache.org/jira/browse/SIS-497 - posted by de...@apache.org on 2020/06/30 10:43:26 UTC, 0 replies.
- [jira] [Commented] (SIS-497) ResamplingGrid should be incremental - posted by "Martin Desruisseaux (Jira)" <ji...@apache.org> on 2020/06/30 10:48:00 UTC, 0 replies.