You are viewing a plain text version of this content. The canonical link for it is here.
- [roller] branch master updated (f70b8d5 -> e8f868b) - posted by sn...@apache.org on 2021/01/01 15:23:46 UTC, 0 replies.
- [roller] branch master updated: back-out change to Spring dependency. - posted by sn...@apache.org on 2021/01/02 15:09:15 UTC, 0 replies.
- [roller] branch master updated: fixing sonarqube issue - static members should be accessed statically - posted by ad...@apache.org on 2021/01/04 04:19:57 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - 'public static' fields should be constant There is no good reason to declare a field public and static without also declaring it final. Most of the time this is a kludge to share a state among several objects. But with this approach, any object can do whatever it wants with the shared state, such as setting it to null. - posted by ad...@apache.org on 2021/01/04 06:23:32 UTC, 0 replies.
- [roller] branch master updated: Create codeql-analysis.yml - posted by ad...@apache.org on 2021/01/04 06:27:09 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - Empty blocks should be removed Leftover empty blocks are usually introduced by mistake. They are useless and prevent readability of the code. They should be removed or completed with real code. - posted by ad...@apache.org on 2021/01/04 08:08:52 UTC, 0 replies.
- [roller] branch master updated (07dcff1 -> 793310a) - posted by ad...@apache.org on 2021/01/04 13:09:16 UTC, 0 replies.
- [roller] 01/05: Fixed: sonarqube issue - strike was redundant - posted by ad...@apache.org on 2021/01/04 13:09:17 UTC, 0 replies.
- [roller] 02/05: Fixed: sonarqube issue - 'i' is already defined Variables and functions should not be redeclared Used let to provide let scope to it - posted by ad...@apache.org on 2021/01/04 13:09:18 UTC, 0 replies.
- [roller] 03/05: Fixed: sonarqube issue - 'e' is already declared in the upper scope - posted by ad...@apache.org on 2021/01/04 13:09:19 UTC, 0 replies.
- [roller] 04/05: Fixed: sonarqube issue - 'checked' is already defined Variables and functions should not be redeclared - posted by ad...@apache.org on 2021/01/04 13:09:20 UTC, 0 replies.
- [roller] 05/05: Fixed: sonarqube issue - 'toggle' is already declared in the upper scope Variables should not be shadowed - posted by ad...@apache.org on 2021/01/04 13:09:21 UTC, 0 replies.
- [roller] branch master updated: Update codeql-analysis.yml - posted by ad...@apache.org on 2021/01/04 14:54:40 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - Constructors of an 'abstract' class should not be declared 'public' Abstract classes should not have public constructors. Constructors of abstract classes can only be called in constructors of their subclasses. So there is no point in making them public. The protected modifier should be enough. - posted by ad...@apache.org on 2021/01/05 05:46:13 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - removed unused private fields - posted by ad...@apache.org on 2021/01/05 05:56:57 UTC, 0 replies.
- [roller] branch master updated (8b6e2b2 -> b8ea634) - posted by ad...@apache.org on 2021/01/05 06:17:21 UTC, 0 replies.
- [roller] 01/02: Fixed: sonarqube issue - Static non-final field names should comply with a naming convention - posted by ad...@apache.org on 2021/01/05 06:17:22 UTC, 0 replies.
- [roller] 02/02: Fixed: sonarqube issue - Boolean​(String s) constructor is deprecated Used parseBoolean(String) to convert a string to a boolean primitive https://docs.oracle.com/javase/9/docs/api/java/lang/Boolean.html#Boolean-java.lang.String- - posted by ad...@apache.org on 2021/01/05 06:17:23 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - 'Random' objects should be reused Creating a new Random object each time a random value is needed is inefficient and may produce numbers which are not random depending on the JDK. For better efficiency and randomness, create a single Random, then store, and reuse it. - posted by ad...@apache.org on 2021/01/05 11:42:53 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - used prepared statement instead of create statement - posted by ad...@apache.org on 2021/01/06 07:06:48 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - Used try-with-resources for the PreparedStatement - posted by ad...@apache.org on 2021/01/06 07:33:37 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - Methods returns should not be invariant When a method is designed to return an invariant value, it may be poor design, but it shouldn't adversely affect the outcome of your program. However, when it happens on all paths through the logic, it is surely a bug. - posted by ad...@apache.org on 2021/01/30 11:02:39 UTC, 0 replies.
- [roller] branch master updated: Fixed: sonarqube issue - used try with resource for BufferedReader Connections, streams, files, and other classes that implement the Closeable interface or its super-interface, AutoCloseable, needs to be closed after use. Further, that close call must be made in a finally block otherwise an exception could keep the call from being made. Preferably, when class implements AutoCloseable, resource should be created using try-with-resources pattern and will be closed automatically. - posted by ad...@apache.org on 2021/01/30 14:40:12 UTC, 0 replies.