You are viewing a plain text version of this content. The canonical link for it is here.
- Re: [PR] Improved handling of idle sessions by AbstractIOSessionPool / H2ConnPool [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/10/01 07:41:44 UTC, 7 replies.
- "Use monotonic time for reactor and H2 timeout accounting" Is it worth it? - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/01 08:04:38 UTC, 4 replies.
- [RESULT][VOTE][LAZY] HttpComponents Parent 15 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/01 08:10:08 UTC, 0 replies.
- [PR] Bump actions/checkout from 5 to 7 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/01 13:23:41 UTC, 1 replies.
- Re: [PR] Bump the all group across 1 directory with 11 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/01 13:24:36 UTC, 4 replies.
- [PR] Bump the all group across 1 directory with 12 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/01 13:25:09 UTC, 14 replies.
- Re: [PR] HTTP/2: Correct pushed response message handling [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/01 13:48:32 UTC, 0 replies.
- Re: [PR] Reject malformed HTTP/2 response headers [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/01 13:48:55 UTC, 0 replies.
- [PR] Bump the all group with 9 updates [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/01 14:12:06 UTC, 2 replies.
- [PR] Bump actions/cache from 5 to 6 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/01 14:12:18 UTC, 1 replies.
- Re: [PR] Send RST_STREAM for a cancelled half-closed stream [httpcomponents-core] - posted by "rp-arielrodriguez (via GitHub)" <gi...@apache.org> on 2026/10/01 14:54:18 UTC, 0 replies.
- [PR] Complete I/O reactor termination when the selector has been closed by another thread [httpcomponents-core] - posted by "AdzerKI (via GitHub)" <gi...@apache.org> on 2026/10/02 02:30:54 UTC, 2 replies.
- [PR] Bump the all group across 1 directory with 5 updates [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/02 07:44:47 UTC, 1 replies.
- [PR] Restore absolute millisecond timestamps in I/O reactor and H2 [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/02 08:08:15 UTC, 1 replies.
- Re: [PR] Correct handling of unsigned HTTP/2 SETTINGS values [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/10/02 08:20:16 UTC, 7 replies.
- [jira] [Created] (HTTPCORE-801) Use long to represent 32 bit unsigned values used by HTTP/2 protocol - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/10/03 09:49:00 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-802) jdk.net.ExtendedSocketOptions causes compatibility problems with newer JDKs - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/10/03 10:36:00 UTC, 0 replies.
- jdk.net.ExtendedSocketOptions / Java 8 compatibility grief - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/03 10:40:20 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-802) jdk.net.ExtendedSocketOptions causes compatibility problems with newer JDKs - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/10/03 10:48:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-802) jdk.net.ExtendedSocketOptions causes compatibility problems with newer JDKs - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/10/03 11:47:00 UTC, 2 replies.
- [PR] Removed testing framework unused and unmaintained since its contribution in 2026 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/10/03 13:53:55 UTC, 0 replies.
- [PR] Reclaim idle connections across routes in RouteSegmentedConnPool [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/03 15:29:43 UTC, 0 replies.
- [jira] [Updated] (HTTPCORE-802) Re-enable release target validation - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2026/10/04 11:21:00 UTC, 0 replies.
- HttpClient 5.6.5 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/04 15:41:03 UTC, 0 replies.
- Re: [PR] HTTPCLIENT-2429: Improve support for custom transport layers [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/05 08:44:18 UTC, 2 replies.
- Re: [PR] Demo for Java 22+ Async SPNEGO breakage [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/10/05 16:23:48 UTC, 0 replies.
- [PR] treat a lone CR as an SSE line terminator [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/10/05 19:44:02 UTC, 3 replies.
- [PR] SSE: Do not dispatch incomplete events at end of stream [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/06 10:28:13 UTC, 1 replies.
- [PR] SSE: Update Last-Event-ID independently of event dispatch [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/06 11:55:29 UTC, 1 replies.
- [PR] SSE: Handle request header names case-insensitively [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/06 14:31:37 UTC, 1 replies.
- [VOTE] Release HttpClient 5.6.5 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/06 19:10:06 UTC, 5 replies.
- Re: [PR] Removed testing framework unused and unmaintained since its contribution in 2016 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2026/10/06 19:10:30 UTC, 0 replies.
- Re: [PR] Add support for Compression Dictionary Transport (RFC 9842) [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/07 10:43:57 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2429) Improve support for custom transport layers - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2026/10/07 10:45:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2429) Improve support for custom transport layers - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/10/07 10:46:00 UTC, 0 replies.
- [jira] [Closed] (HTTPCLIENT-2429) Improve support for custom transport layers - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2026/10/07 10:46:00 UTC, 0 replies.
- [PR] HTTPCORE-801: Use long for unsigned 32-bit HTTP/2 values [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/07 11:49:05 UTC, 3 replies.
- Re: [PR] RFC 9421: HTTP Message Signatures [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/07 12:34:02 UTC, 4 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.6.5 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/10 10:14:34 UTC, 0 replies.
- HttpCore 5.5-beta4 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/10 12:32:59 UTC, 5 replies.
- [PR] Bump the all group across 1 directory with 10 updates [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2026/10/10 13:31:02 UTC, 1 replies.
- [VOTE] Release HttpCore 5.5-beta4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/10 20:20:41 UTC, 3 replies.
- [PR] require scram server nonce to extend the client nonce [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/10/11 06:28:54 UTC, 2 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.6.5 Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/12 18:11:29 UTC, 0 replies.
- [PR] Tighten RFC 7804 SCRAM message validation. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/13 10:27:00 UTC, 1 replies.
- [PR] Fix spurious TCP resets when initiating TLS connection closure [httpcomponents-client] - posted by "rschmitt (via GitHub)" <gi...@apache.org> on 2026/10/13 21:01:10 UTC, 3 replies.
- [VOTE][RESULT] Release HttpCore 5.5-beta4 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/14 09:08:53 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.5-beta4 released - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/14 15:11:31 UTC, 0 replies.
- HttpClient 5.7-beta1 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/15 10:19:49 UTC, 4 replies.
- [PR] Add RFC 9211 to the list of supported specifications [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/18 06:16:03 UTC, 1 replies.
- [VOTE] Release HttpClient 5.7-beta1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/19 19:29:39 UTC, 3 replies.
- [PR] strip control characters when writing the cookie header [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/10/20 05:31:55 UTC, 10 replies.
- [PR] Reject malformed HTTP/1 header fields and trailers in both classic and async transports. [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/21 08:49:28 UTC, 6 replies.
- [PR] Filter control characters in encoded HTTP/1 output lines [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/21 11:13:59 UTC, 2 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.7-beta1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2026/10/22 10:08:17 UTC, 0 replies.
- Re: [PR] reject cookies with control characters as invalid [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/10/23 07:25:40 UTC, 0 replies.
- [PR] Fix SCRAM authentication lifecycle across consecutive requests [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2026/10/23 12:22:41 UTC, 0 replies.
- [PR] strip trailing dot before matching spki pinning rules [httpcomponents-client] - posted by "dxbjavid (via GitHub)" <gi...@apache.org> on 2026/10/23 14:29:55 UTC, 0 replies.