You are viewing a plain text version of this content. The canonical link for it is here.
- (sis) branch geoapi-4.0 updated: Do not allow a Landsat MLT file to refer a TIFF image outside the scene directory. - posted by de...@apache.org on 2026/09/02 13:40:47 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Test warning by registering a listener instead of watching the logger. - posted by de...@apache.org on 2026/09/03 10:16:49 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (7eee5e5401 -> e88cd848af) - posted by js...@apache.org on 2026/09/03 14:41:56 UTC, 0 replies.
- (sis) 01/02: feat(Geometry): implement several geometry types - posted by js...@apache.org on 2026/09/03 14:41:57 UTC, 0 replies.
- (sis) 02/02: feat(GML): add GML geometry bindings - posted by js...@apache.org on 2026/09/03 14:41:58 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add ArcByBulge and ArcByCenterPoint - posted by js...@apache.org on 2026/09/04 08:10:26 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): replace List by Array for data points and control points properties - posted by js...@apache.org on 2026/09/04 13:32:40 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (db3ac3f29b -> 3967f8b543) - posted by js...@apache.org on 2026/09/07 08:51:57 UTC, 0 replies.
- (sis) 01/06: feat(Geometry): fuze SIS getPoints() and ISO getDataPoints() as getDataPoints() - posted by js...@apache.org on 2026/09/07 08:51:58 UTC, 0 replies.
- (sis) 02/06: refactor(Geometry): rename PointSequence to DataPoints to follow ISO:19107 naming - posted by js...@apache.org on 2026/09/07 08:51:59 UTC, 0 replies.
- (sis) 03/06: feat(Geometry): add geodesic curve implementation - posted by js...@apache.org on 2026/09/07 08:52:00 UTC, 0 replies.
- (sis) 04/06: refactor(Geometry): regroup curve interfaces in a single package - posted by js...@apache.org on 2026/09/07 08:52:01 UTC, 0 replies.
- (sis) 05/06: refactor(Math): move math package outside geometries - posted by js...@apache.org on 2026/09/07 08:52:02 UTC, 0 replies.
- (sis) 06/06: refactor(Geometry): regroup point,curve,surface,solid in dedicated pacakages - posted by js...@apache.org on 2026/09/07 08:52:03 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add rhumb line - posted by js...@apache.org on 2026/09/07 09:19:56 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (d07197bd1a -> 85a2bc7477) - posted by js...@apache.org on 2026/09/08 08:27:02 UTC, 0 replies.
- (sis) 01/03: feat(Geometry): add Vector.lerp, Matrices.solve and DeBoorAlgorithm for spline resolutions - posted by js...@apache.org on 2026/09/08 08:27:03 UTC, 0 replies.
- (sis) 02/03: feat(Geometry): replace knot object list by flat double[] array - posted by js...@apache.org on 2026/09/08 08:27:04 UTC, 0 replies.
- (sis) 03/03: feat(Geometry): add an incomplete implementation of nurbs curve and surface - posted by js...@apache.org on 2026/09/08 08:27:05 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: refactor(Geometry): seal geometry interfaces - posted by js...@apache.org on 2026/09/08 10:23:53 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add Vector.slerp, support Tuple arrays in ArrayFactory - posted by js...@apache.org on 2026/09/08 15:08:49 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(DBF): fix read and write support for deleted dbf records - posted by js...@apache.org on 2026/09/09 09:01:03 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (7eb41f2d3f -> 855247d94d) - posted by js...@apache.org on 2026/09/09 09:50:12 UTC, 0 replies.
- (sis) 01/02: feat(SHP): support null geometries - posted by js...@apache.org on 2026/09/09 09:50:13 UTC, 0 replies.
- (sis) 02/02: feat(SHP): review how ids are used, preserve them after a delete operation. Add Store.compact method to clean deleted records - posted by js...@apache.org on 2026/09/09 09:50:14 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: doc(Geometry): add full javadoc on Curve interface - posted by js...@apache.org on 2026/09/09 12:53:31 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (719800b92b -> 00f8738191) - posted by js...@apache.org on 2026/09/09 15:00:36 UTC, 0 replies.
- (sis) 01/02: feat(Geometry): add Geometry javadoc - posted by js...@apache.org on 2026/09/09 15:00:37 UTC, 0 replies.
- (sis) 02/02: feat(Geometry): add Surface and Solid javadoc - posted by js...@apache.org on 2026/09/09 15:00:38 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: doc(Geometry): add javadoc on remaining geometry subtypes interfaces - posted by js...@apache.org on 2026/09/10 12:17:04 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (8d99394ab2 -> 57b466cbb6) - posted by js...@apache.org on 2026/09/11 09:18:09 UTC, 0 replies.
- (sis) 01/03: refactor(Geometry): remove unecessary public keyword on interfaces - posted by js...@apache.org on 2026/09/11 09:18:10 UTC, 0 replies.
- (sis) 02/03: feat(Geometry): define all describe parameters on geometry interfaces - posted by js...@apache.org on 2026/09/11 09:18:11 UTC, 0 replies.
- (sis) 03/03: feat(Geometry): add WKT encoding - posted by js...@apache.org on 2026/09/11 09:18:12 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (57b466cbb6 -> 0fdcad59b7) - posted by js...@apache.org on 2026/09/11 12:27:28 UTC, 0 replies.
- (sis) 01/02: feat(Shapefile): add new types of store event - posted by js...@apache.org on 2026/09/11 12:27:29 UTC, 0 replies.
- (sis) 02/02: feat(Shapefile): send events on featuretype on features changes - posted by js...@apache.org on 2026/09/11 12:27:30 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (0fdcad59b7 -> 44c63d5f25) - posted by de...@apache.org on 2026/09/14 03:30:02 UTC, 0 replies.
- (sis) 01/02: Remove a `requires` statement which does not seem necessary. - posted by de...@apache.org on 2026/09/14 03:30:03 UTC, 0 replies.
- (sis) 02/02: Add a safety against array of unreasonable length in netCDF and TIFF files. - posted by de...@apache.org on 2026/09/14 03:30:04 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (44c63d5f25 -> fde8dfe830) - posted by js...@apache.org on 2026/09/14 15:21:19 UTC, 0 replies.
- (sis) 01/02: feat(Geometry): implement several small methods - posted by js...@apache.org on 2026/09/14 15:21:20 UTC, 0 replies.
- (sis) 02/02: feat(Shapefile): minor changes on event classes - posted by js...@apache.org on 2026/09/14 15:21:21 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: fix(Referencing): prevent NPE when searching an identifier - posted by am...@apache.org on 2026/09/15 06:39:09 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: During XML unmarshalling, if a `xlink:href` is not local (i.e. starts with `#`), resolve only if explicitely authorized by the user. Otherwise leave the element empty. - posted by de...@apache.org on 2026/09/15 10:41:14 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Rename `OPEN_EXTERNAL_DOCUMENTS` as `FOLLOW_EXTERNAL_XLINK`. - posted by de...@apache.org on 2026/09/15 11:00:55 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: chore(Geometry): prepare test classes and methods - posted by js...@apache.org on 2026/09/16 09:22:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): implement WKB Reader and Writer - posted by js...@apache.org on 2026/09/16 12:38:30 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add EWKT and EWKB support - posted by js...@apache.org on 2026/09/16 13:35:25 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): handle the case where an EWKT/EWKN geometry define a 2d crs with a Z value, ellipsoid height is added - posted by js...@apache.org on 2026/09/16 14:08:05 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: chore(Geometry): remove TWKB flavor, found no usage of it outside postgis and format is experimental - posted by js...@apache.org on 2026/09/16 14:29:40 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (e6d143773b -> fa672af7ba) - posted by js...@apache.org on 2026/09/17 13:50:07 UTC, 0 replies.
- (sis) 01/02: feat(Geometry): add default empty geometry classes implementations and factory methods - posted by js...@apache.org on 2026/09/17 13:50:08 UTC, 0 replies.
- (sis) 02/02: feat(Geometry): replace fixed length,area,volume by Quantity> to handle dimensionless and temporal geometries - posted by js...@apache.org on 2026/09/17 13:50:09 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: refactor(Geometry): regroup Geometry.buffer operations, fix locateAlong and locateBetween missing parameter name - posted by js...@apache.org on 2026/09/18 07:37:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add a D9IM matrix class, replacing int and string patterns - posted by js...@apache.org on 2026/09/18 08:42:40 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: chore(Geometry): reorganize test classes, prepare test classes for default implementations - posted by js...@apache.org on 2026/09/18 09:15:57 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Reduce the number of constructors of `GridFile` to one. The intend is to have a single place where to validate URIs. - posted by de...@apache.org on 2026/09/19 16:53:15 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): implement all tests for Empty geometry type - posted by js...@apache.org on 2026/09/21 08:38:43 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): solve geometryType difference between OGC SFA and ISO 19107, renmae AttributesType to DataPointsType - posted by js...@apache.org on 2026/09/21 12:46:57 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): review and add Bearing implementation - posted by js...@apache.org on 2026/09/21 15:08:22 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Add access control when opening a datum shift grid file. The operation is denied if the WKT `PARAMETERFILE` value is not relative to the `$SIS_DATA/DatumChanges` directory or a sibling of the file that provide the WKT definition. This default behavior can be customized. - posted by de...@apache.org on 2026/09/22 03:58:26 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(Geometry): add point geometry tests - posted by js...@apache.org on 2026/09/22 12:57:46 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Use `org.apache.sis.io.Authorization` for the GML access control of "xlink:href" attributes. - posted by de...@apache.org on 2026/09/23 13:38:54 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (8e8f2e2b92 -> 2cc5bb50ba) - posted by de...@apache.org on 2026/09/29 00:09:13 UTC, 0 replies.
- (sis) 01/02: Cleanup related to relative files in WKT parameters. - posted by de...@apache.org on 2026/09/29 00:09:14 UTC, 0 replies.
- (sis) 02/02: Add a property for declaring that the environment is trusted. In trusted environment, some security constraints are relaxed. - posted by de...@apache.org on 2026/09/29 00:09:15 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Double quote the quotes in identifiers inside SQL statements. - posted by de...@apache.org on 2026/09/29 13:10:49 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (80c161ba8d -> fac1549bcd) - posted by de...@apache.org on 2026/09/29 15:41:58 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1 - posted by de...@apache.org on 2026/09/29 15:41:59 UTC, 0 replies.