You are viewing a plain text version of this content. The canonical link for it is here.
- (sis) branch geoapi-4.0 updated (7a507877d4 -> f583861e3d) - posted by de...@apache.org on 2026/04/05 17:12:15 UTC, 0 replies.
- (sis) 01/02: Add a convenience `MemoryGridCoverageResource` constructor taking only a `GridCoverage` argument. - posted by de...@apache.org on 2026/04/05 17:12:16 UTC, 0 replies.
- (sis) 02/02: Initial rewrite of the system for showing data in separated windows. The new `MapWindows` class is intended to replace `WindowManager`. This first draft can show many `MapCanvas` in a mosaic. - posted by de...@apache.org on 2026/04/05 17:12:17 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Initial support of gesture synchronization between map canvases in the same mosaic. This initial version only adds the visualization of the mouse position in other canvases. - posted by de...@apache.org on 2026/04/07 22:26:44 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: More complete implementation of `MapCanvas.clear()`. It resolves a problem of map upside-down when a `MapCanvas` is reused. - posted by de...@apache.org on 2026/04/08 10:18:41 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Allow to move simultaneously in all canvases shown in the same window. Contains a bug fix for handling retroaction (moving A moves B which moves A). - posted by de...@apache.org on 2026/04/10 11:03:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Remove from the GUI and deprecate in the API the old windows system. - posted by de...@apache.org on 2026/04/10 11:24:09 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (1f908a0fb4 -> 8b39502182) - posted by de...@apache.org on 2026/04/13 14:10:00 UTC, 0 replies.
- (sis) 01/02: Add tooltip texts. - posted by de...@apache.org on 2026/04/13 14:10:01 UTC, 0 replies.
- (sis) 02/02: Spelling fixes. - posted by de...@apache.org on 2026/04/13 14:10:02 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (a175b926cf -> a8a2df6ef0) - posted by de...@apache.org on 2026/04/13 21:01:37 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. Replacement of the synchronized windows features of the JavaFX application. - posted by de...@apache.org on 2026/04/13 21:01:38 UTC, 0 replies.
- (sis) branch main updated (73383b6907 -> 8a62a3c524) - posted by de...@apache.org on 2026/04/13 21:02:37 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1' - posted by de...@apache.org on 2026/04/13 21:02:38 UTC, 1 replies.
- (sis) branch geoapi-4.0 updated: Update for a change in GeoAPI development branch. The way to declare a `CodeList` had to change in order to avoid a deadlock which occurred at class initialization time. The fix is to use less magic in the `CodeList` parent class, which requires that subclasses declare `VALUES` themselves. - posted by de...@apache.org on 2026/04/13 21:29:15 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Reduce a little bit the needs to use reflection for getting code list values. - posted by de...@apache.org on 2026/04/14 10:56:19 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (a8a2df6ef0 -> 9b695745b2) - posted by de...@apache.org on 2026/04/14 11:02:18 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. This is a change in GeoAPI `CodeList` for avoiding a deadlock. - posted by de...@apache.org on 2026/04/14 11:02:19 UTC, 0 replies.
- (sis) branch main updated (8a62a3c524 -> 96e4ba9bde) - posted by de...@apache.org on 2026/04/14 11:30:26 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: GeoTIFF `getTileMatrixSets()` method should return an empty set if the image is not tiled. - posted by de...@apache.org on 2026/04/14 23:28:20 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(StorageConnector): add contentStartWith and pathEndsWith probing methods - posted by js...@apache.org on 2026/04/15 10:20:50 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (c199e06898 -> 91538a6510) - posted by de...@apache.org on 2026/04/15 11:27:03 UTC, 0 replies.
- (sis) 01/02: Edit documentation, add `@see` tags, avoid forcing conversion to URI. - posted by de...@apache.org on 2026/04/15 11:27:04 UTC, 0 replies.
- (sis) 02/02: Complete the help method for creating a coverage from functions. A variant working of floating-point values is added. The image size argument is replaced by image bounds. - posted by de...@apache.org on 2026/04/15 11:27:05 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: feat(GridExtent): add GridExtent.interiorCoordinateStream method - posted by js...@apache.org on 2026/04/15 12:36:57 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: fix(Shapefile): fix provider not returned - posted by js...@apache.org on 2026/04/15 14:47:13 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (cbba27224d -> 69dc8bbe5b) - posted by de...@apache.org on 2026/04/15 15:41:43 UTC, 0 replies.
- (sis) 01/02: For GeoTIFF reader, `getTileMatrixSets()` returns an empty collection for images encoded with strips instead of tiles. - posted by de...@apache.org on 2026/04/15 15:41:44 UTC, 0 replies.
- (sis) 02/02: Rename `interiorCoordinateStream()` as `latticePointStream(boolean parallel)` and implement using `Spliterator` (more efficient, specify characteristics). - posted by de...@apache.org on 2026/04/15 15:41:45 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Revert the removal of the escape character sequences in `ScriptRunner`. This removal was done in commit 967360a5f7c37127c9e1cec5a00605c5246168f0 because escape was not used by Apache SIS for metadata and EPSG scripts. However, we depend on it for prototypes in external repositories, and there is a possibility that SIS needs escaping in the future. - posted by de...@apache.org on 2026/04/15 16:17:00 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Change policy about the ordering of lattice: make the ordering part of the method contract. - posted by de...@apache.org on 2026/04/15 21:43:04 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Bug fix in the drawing of shapes of loaded tiles: the objective CRS, objective to display transform and the list where shapes are added must be obtained together for consistency. Before this commit, the list of shapes where obtained some time after the transform, resulting in a sometime outdated transform. - posted by de...@apache.org on 2026/04/16 16:07:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Rename `ObjectiveSnapshot` as `StaticGraphics`. - posted by de...@apache.org on 2026/04/17 09:47:38 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (1312af30fb -> 11bd7f071e) - posted by de...@apache.org on 2026/04/17 09:50:12 UTC, 0 replies.
- (sis) 01/01: Rename `ObjectiveSnapshot` as `StaticGraphics`. - posted by de...@apache.org on 2026/04/17 09:50:13 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Check for stream of unknown length when writing GeoTIFF images. - posted by de...@apache.org on 2026/04/17 13:12:16 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (9b695745b2 -> 5acd0c2351) - posted by de...@apache.org on 2026/04/17 13:46:53 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. This is mostly bug fixes. - posted by de...@apache.org on 2026/04/17 13:46:54 UTC, 0 replies.
- (sis) branch main updated (96e4ba9bde -> f70b0f2ffd) - posted by de...@apache.org on 2026/04/17 13:51:49 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1'. - posted by de...@apache.org on 2026/04/17 13:51:50 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (170703b77e -> 02fc9f92a2) - posted by de...@apache.org on 2026/04/18 09:01:27 UTC, 0 replies.
- (sis) 01/02: Post-merge automatic reorganization of imports order. - posted by de...@apache.org on 2026/04/18 09:01:28 UTC, 0 replies.
- (sis) 02/02: Bug fixes and improvements in the GeoTIFF writer. - Fix a "cannot write" exception when the operation method was not an instance of `AbstractMethod`. - Fix the test failure when the project was built in an environment without connection to an EPSG database. - Write both the EPSG codes and the CRS elements for helping applications that do not have access to an EPSG database. Before this commit, the writer omitted the CRS elements if EPSG codes were present for avoiding duplication. - posted by de...@apache.org on 2026/04/18 09:01:29 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (5acd0c2351 -> a646368864) - posted by de...@apache.org on 2026/04/18 09:03:10 UTC, 0 replies.
- (sis) 01/02: Merge of automatic reorganization of imports order. - posted by de...@apache.org on 2026/04/18 09:03:11 UTC, 1 replies.
- (sis) 02/02: Merge branch 'geoapi-4.0' into geoapi-3.1 - posted by de...@apache.org on 2026/04/18 09:03:12 UTC, 0 replies.
- (sis) branch main updated (f70b0f2ffd -> eb71d2424c) - posted by de...@apache.org on 2026/04/18 09:05:01 UTC, 0 replies.
- (sis) 02/02: Merge branch 'geoapi-3.1' - posted by de...@apache.org on 2026/04/18 09:05:03 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Status bar should rewrite coordinates with new accuracy after zoom event. - posted by de...@apache.org on 2026/04/20 13:59:30 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (d56a95f9fa -> 968f30a4fb) - posted by de...@apache.org on 2026/04/22 12:09:21 UTC, 0 replies.
- (sis) 01/02: Fix a wrong transformation of coordinates after a change of CRS in the status bar. Documentation improvement as a side-effect of the search for the bug. - posted by de...@apache.org on 2026/04/22 12:09:22 UTC, 0 replies.
- (sis) 02/02: Show the name of the map projection in multi-canvas views too. Before this commit, it was shown only in the overview. - posted by de...@apache.org on 2026/04/22 12:09:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: fix(GridExtent): fix a missing point coordinate clone in GridExtent lattice stream - posted by js...@apache.org on 2026/04/22 13:43:06 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Build a gray scale instead of index color model when possible. The use of gray scale allows interpolations, contrarily to index color model. - posted by de...@apache.org on 2026/04/22 17:11:42 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Fix a random test failure. - posted by de...@apache.org on 2026/04/23 09:03:58 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (4fd594d640 -> 5ccba14513) - posted by de...@apache.org on 2026/04/23 16:35:42 UTC, 0 replies.
- (sis) 01/02: Fix a NullPointerException caused by copying array of image property names in the wrong direction. - posted by de...@apache.org on 2026/04/23 16:35:43 UTC, 0 replies.
- (sis) 02/02: More systematic construction of gray scale instead of index color model. - posted by de...@apache.org on 2026/04/23 16:35:44 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (5ccba14513 -> 2d623b02d0) - posted by de...@apache.org on 2026/04/24 22:52:33 UTC, 0 replies.
- (sis) 01/02: Avoid repeating the same warnings twice after WKT formatting of a CRS. - posted by de...@apache.org on 2026/04/24 22:52:34 UTC, 0 replies.
- (sis) 02/02: More robust creation of the CRS for grid coordinates: if we cannot create a DerivedCRS, fallback on EngineeringCRS. - posted by de...@apache.org on 2026/04/24 22:52:35 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (2d623b02d0 -> 3278ea0871) - posted by de...@apache.org on 2026/04/27 16:17:34 UTC, 0 replies.
- (sis) 01/02: Reintroduce `DefiningConversion` with an optional property for specifying whether the conversion is fully-defined or apply between normalized coordinate systems. - posted by de...@apache.org on 2026/04/27 16:17:35 UTC, 0 replies.
- (sis) 02/02: Add `GridExtent.derivativeAtPOI(…)` internal method for convenience. - posted by de...@apache.org on 2026/04/27 16:17:36 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: More robust implementation of `GridGeometry.createGridCRS(…)`, trying harder to infer axis directions. - posted by de...@apache.org on 2026/04/28 17:47:09 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Fix a few holes in the implementation of `createGridCRS` and expand the test. - posted by de...@apache.org on 2026/04/29 22:24:15 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Try harder to restrict the CRS choices of a `CoverageCanvas` to valid CRS. We use the datum as a quick filter. We also need to ensure that the canvas is initialized with the engineering CRS of the coverage, not of the canvas, when the coverage has no geodetic CRS. - posted by de...@apache.org on 2026/04/30 16:42:06 UTC, 0 replies.