You are viewing a plain text version of this content. The canonical link for it is here.
- [jira] [Commented] (HTTPCLIENT-2405) ConnectionReuse uses connectTimeout as readTimeout on reused connection - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/01 09:52:00 UTC, 3 replies.
- [jira] [Commented] (HTTPCORE-787) URIBuilder.getPath() should escape each segment - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/01 10:06:00 UTC, 0 replies.
- Re: [PR] Bump io.opentelemetry:opentelemetry-bom from 1.49.0 to 1.55.0 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/01 16:05:37 UTC, 0 replies.
- Re: [PR] Bump com.github.luben:zstd-jni from 1.5.7-4 to 1.5.7-6 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/01 16:06:00 UTC, 0 replies.
- Re: [PR] Bump org.ehcache.modules:ehcache-api from 3.10.8 to 3.11.1 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/01 16:06:33 UTC, 0 replies.
- Re: [PR] Bump micrometer.tracing.version from 1.5.2 to 1.5.5 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/01 16:07:13 UTC, 0 replies.
- Re: [PR] Bump micrometer.version from 1.15.2 to 1.15.5 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/01 16:57:38 UTC, 0 replies.
- [PR] HTTPCORE-637: RFC 3986 URI: parse/resolve/normalize. [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/11/01 19:17:54 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2405) ConnectionReuse uses connectTimeout as readTimeout on reused connection - posted by "Henrik Dohlmann (Jira)" <ji...@apache.org> on 2025/11/03 09:35:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2405) ConnectionReuse uses connectTimeout as readTimeout on reused connection - posted by "Henrik Dohlmann (Jira)" <ji...@apache.org> on 2025/11/03 09:57:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2405) ConnectionReuse uses connectTimeout as readTimeout on reused connection - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/03 11:21:00 UTC, 0 replies.
- Re: [PR] Demo for Java 22+ Async SPNEGO breakage [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/04 06:15:41 UTC, 2 replies.
- [jira] [Commented] (HTTPCLIENT-2402) Handle SecurityManager removal - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/04 18:06:00 UTC, 0 replies.
- [PR] Route-segmented pool: fix timeout race; direct hand-off; bound scans [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/11/06 16:59:19 UTC, 2 replies.
- [PR] Bump junit.version from 5.13.3 to 6.0.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/07 13:01:49 UTC, 3 replies.
- [PR] Bump micrometer.tracing.version from 1.5.5 to 1.6.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/07 13:02:09 UTC, 0 replies.
- [PR] Bump micrometer.version from 1.15.5 to 1.16.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/07 13:02:44 UTC, 0 replies.
- [PR] Bump org.junit:junit-bom from 5.14.0 to 5.14.1 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/07 14:01:28 UTC, 0 replies.
- Pull request backlog - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/11/10 17:42:05 UTC, 1 replies.
- [jira] [Created] (HTTPCLIENT-2406) MemcachedHttpCacheStorage always stores data in remote store with zero expiration. - posted by "Akash (Jira)" <ji...@apache.org> on 2025/11/12 21:26:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2406) MemcachedHttpCacheStorage always stores data in remote store with zero expiration. - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/13 10:33:00 UTC, 2 replies.
- [PR] HTTPCLIENT-2406 - Add configurable memcached TTL to HTTP cache storage. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/11/14 08:50:21 UTC, 1 replies.
- [PR] Add configurable TTL to memcached cache storage. [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/11/14 09:35:25 UTC, 1 replies.
- [PR] Bump otel.version from 1.55.0 to 1.56.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/14 13:01:35 UTC, 0 replies.
- [PR] Bump junit.version from 5.13.3 to 5.14.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/14 13:01:36 UTC, 0 replies.
- [PR] Bump io.opentelemetry:opentelemetry-bom from 1.55.0 to 1.56.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/14 13:01:42 UTC, 0 replies.
- [PR] Bump commons-cli:commons-cli from 1.10.0 to 1.11.0 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/14 14:01:43 UTC, 0 replies.
- [PR] Add pooled ByteBuffer allocator with size classes [httpcomponents-core] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/11/14 19:17:59 UTC, 5 replies.
- Re: [PR] Introduce Caffeine-based cache backend [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2025/11/15 12:18:01 UTC, 0 replies.
- [PR] Bump actions/checkout from 5 to 6 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/21 13:01:15 UTC, 0 replies.
- [PR] Bump actions/checkout from 5 to 6 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2025/11/21 14:01:13 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2406) MemcachedHttpCacheStorage always stores data in remote store with zero expiration. - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/22 11:10:00 UTC, 0 replies.
- [PR] HTTPCLIENT-2406: MemcachedHttpCacheStorage to support per entry expiry setting [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/22 12:13:39 UTC, 2 replies.
- [DISCUSS] HTTPCLIENT-2381 use 'runtime' proxy activation by default - posted by Jon Harper <jo...@gmail.com> on 2025/11/24 13:22:45 UTC, 1 replies.
- [jira] [Resolved] (HTTPCLIENT-2406) MemcachedHttpCacheStorage always stores data in remote store with zero expiration. - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/24 16:52:00 UTC, 0 replies.
- Re: [DISCUSS] HTTPCLIENT-2381 read system properties by default - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/11/24 17:02:17 UTC, 3 replies.
- [jira] [Commented] (HTTPCLIENT-2404) Provide comprehensive timeout configuration documentation with interaction matrix and override behavior - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/29 09:10:00 UTC, 0 replies.
- Re: [PR] Implements RFC 8470 “Using Early Data in HTTP” [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/29 10:33:32 UTC, 0 replies.
- [VOTE][LAZY] HTTPCLIENT-2381 read system properties by default - posted by Oleg Kalnichevski <ol...@apache.org> on 2025/11/29 15:21:01 UTC, 3 replies.
- Re: [PR] HTTPCLIENT-1074: Hard request timeout (requestTimeout) for async & classic clients [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/29 16:29:59 UTC, 6 replies.
- Re: [PR] HTTPCLIENT-2396 - add Server-Sent Events client to HttpClient5. [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/29 16:39:42 UTC, 1 replies.
- Re: [PR] HTTPCLIENT-2398 - Cap async execution queue to break recursive re-entry [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/29 16:40:52 UTC, 4 replies.
- Re: [PR] RFC 7639 ALPN [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2025/11/29 16:47:24 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2374) Document CONNECTION_TIME_TO_LIVE semantic change in migration guide (timeToLive=0 behavior) - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2025/11/30 13:18:00 UTC, 0 replies.