You are viewing a plain text version of this content. The canonical link for it is here.
- (sis) branch geoapi-4.0 updated: Find a coordinate operation path between two CRS when a step requires a change from spherical coordinates to geodetic coordinates. Note: when the spherical coordinates are two-dimensional, current version assumes a radius of zero, which is incorrect. The missing radius problem will be adressed in a separated commit. - posted by de...@apache.org on 2025/06/01 22:43:49 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Add a "Spherical 2D to 3D" operation where the third dimension is the distance R from the centre to the ellipsoid surface. This new operation, while apparently simple, has many implications on the way to concatenate and optimize a chain of transforms. Therefore, this commit also contains: - posted by de...@apache.org on 2025/06/06 19:28:52 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Refactor the `CoordinateOperationFinder.createOperationStep(GeodeticCRS source, GeodeticCRS target)` method for adding a "spherical to ellipsoidal" step (or its inverse) when needed, including addition of radius coordinate ("spherical 2D to 3D"). - posted by de...@apache.org on 2025/06/08 22:26:25 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (f416e5744b -> b1ab7de505) - posted by js...@apache.org on 2025/06/10 14:34:44 UTC, 0 replies.
- (sis) 01/02: Create an initially empty geometry module. - posted by js...@apache.org on 2025/06/10 14:34:45 UTC, 0 replies.
- (sis) 02/02: Add geometry package, merging different specification : ISO-19107, Khronos GLTF, OGC SimpleFeature - posted by js...@apache.org on 2025/06/10 14:34:46 UTC, 0 replies.
- (sis) branch feat/ogr deleted (was afbaafb4f9) - posted by js...@apache.org on 2025/06/11 06:43:55 UTC, 0 replies.
- (sis) branch feat/exportableTransform created (now eaae1fe01c) - posted by js...@apache.org on 2025/06/11 08:14:55 UTC, 0 replies.
- (sis) 01/01: Add ExportableTransform interface - posted by js...@apache.org on 2025/06/11 08:14:56 UTC, 1 replies.
- (sis) branch geoapi-3.1 updated (ffa96dbde4 -> 3abad8c520) - posted by de...@apache.org on 2025/06/11 08:28:51 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. Contains support for conversion from geographic to spherical coordinates without going through Cartesian coordinates, and improvements in `SQLStore` with projections (in SQL sense) of properties that are links (e.g. "sis:identifier"). - posted by de...@apache.org on 2025/06/11 08:28:52 UTC, 0 replies.
- (sis) branch feat/exportableTransform deleted (was eaae1fe01c) - posted by js...@apache.org on 2025/06/11 08:48:26 UTC, 0 replies.
- (sis) branch feat/exportableTransform created (now cb366ebe13) - posted by js...@apache.org on 2025/06/11 08:49:24 UTC, 0 replies.
- (sis) branch main updated (3d377745a9 -> 95d808c404) - posted by de...@apache.org on 2025/06/11 11:07:19 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1'. - posted by de...@apache.org on 2025/06/11 11:07:20 UTC, 0 replies.
- (sis) branch feat/exportableTransform updated (cb366ebe13 -> 9386f8fe78) - posted by js...@apache.org on 2025/06/12 10:07:55 UTC, 0 replies.
- (sis) 01/02: Add ExportableTransform interface - posted by js...@apache.org on 2025/06/12 10:07:56 UTC, 0 replies.
- (sis) 02/02: Implement ExportableTransform for EllipsoidToRadiusTransform - posted by js...@apache.org on 2025/06/12 10:07:57 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (b1ab7de505 -> 652680e4d7) - posted by de...@apache.org on 2025/06/20 17:48:46 UTC, 0 replies.
- (sis) 01/04: Review of the changes in the endorsed part of Apache SIS regarding geometries. Replaced the parameterization of `ensureWinding(…)` by method overloading for avoiding unsafe casts. - posted by de...@apache.org on 2025/06/20 17:48:47 UTC, 0 replies.
- (sis) 02/04: Better error message saying why a `LinearInterpolator1D` cannot be inverted. - posted by de...@apache.org on 2025/06/20 17:48:48 UTC, 0 replies.
- (sis) 03/04: Fix a `NonInvertibleTransformException` in calls to `GridGeometry.createTransformTo(…)` when the number of dimensions is not the same in source and target and some dimensions are non-linear. - posted by de...@apache.org on 2025/06/20 17:48:49 UTC, 0 replies.
- (sis) 04/04: Refactoring of the optimization attempts made during the concatenation of math transforms. The changes concern implementations of `AbstractMathTransform.tryConcatenate(Joiner)`. - posted by de...@apache.org on 2025/06/20 17:48:50 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Be more conservative when analyzing the matrix for pass-through coordinates during the concatenation of two `MathTransform` instances. - posted by de...@apache.org on 2025/06/22 15:22:41 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (1f863a3c4f -> e0a62e0a05) - posted by de...@apache.org on 2025/06/24 14:37:56 UTC, 0 replies.
- (sis) 01/03: Upgrade some dependencies. - posted by de...@apache.org on 2025/06/24 14:37:57 UTC, 0 replies.
- (sis) 02/03: Documentation fixes. - posted by de...@apache.org on 2025/06/24 14:37:58 UTC, 0 replies.
- (sis) 03/03: Remove the call to `PGSimpleDataSource.setCurrentSchema(String)` as it does not work anymore with PostgreSQL 16. https://github.com/pgjdbc/pgjdbc/issues/3685 - posted by de...@apache.org on 2025/06/24 14:37:59 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (e0a62e0a05 -> 9f73d3edf5) - posted by de...@apache.org on 2025/06/24 15:39:04 UTC, 0 replies.
- (sis) 01/02: Rename `getLogRecord` as `createLogRecord` (internal method). - posted by de...@apache.org on 2025/06/24 15:39:05 UTC, 0 replies.
- (sis) 02/02: Rely less on `CommonCRS` and more on `HardCodedCRS` in JUnit tests, for making them less sensitive to whether an EPSG database is present. - posted by de...@apache.org on 2025/06/24 15:39:06 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (3abad8c520 -> cb32b1b2f0) - posted by de...@apache.org on 2025/06/24 15:55:10 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. Contains the introduction of a "geometries" experimental module - this is not committed API. - posted by de...@apache.org on 2025/06/24 15:55:11 UTC, 0 replies.
- (sis) branch main updated (95d808c404 -> 42a3d15915) - posted by de...@apache.org on 2025/06/24 16:23:16 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1', excluding the `org.apache.sis.geometry` module (incubator). That geometry module depends on GeoAPI interfaces that are not released (and may not). A review of the geometry module is necessary before it can be merged to the main branch. - posted by de...@apache.org on 2025/06/24 16:23:17 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Fix a code of `TransformSeparator` where the accurracy of matrix elements could be lost. - posted by de...@apache.org on 2025/06/30 09:00:38 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Refactor matrix classes between sis referencing Matrix and the new geometry module matrix classes - posted by js...@apache.org on 2025/06/30 13:46:10 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Formatting, documentaton and consolidation of argument check. - posted by de...@apache.org on 2025/06/30 16:52:06 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (0dc0e3f417 -> ad6153efb4) - posted by de...@apache.org on 2025/06/30 16:55:40 UTC, 0 replies.
- (sis) 01/01: Minor editions to new matrix methods: - posted by de...@apache.org on 2025/06/30 16:55:41 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (ad6153efb4 -> 6e7b9ad37e) - posted by de...@apache.org on 2025/06/30 17:05:19 UTC, 0 replies.
- (sis) 01/04: Fix documentation relative to EPSG in the `README` files and in Javadoc of installation script providers. Some sentences where from the days when the EPSG optional modules were on the SVN source code repository. - posted by de...@apache.org on 2025/06/30 17:05:20 UTC, 0 replies.
- (sis) 02/04: Write catalog name in a way more compliant with what the database driver expects. Omit the catalog name and/or schema name when they are the current catalog/schema. - posted by de...@apache.org on 2025/06/30 17:05:21 UTC, 0 replies.
- (sis) 03/04: Replace the MS-Access SQL dialect by ANSI SQL in EPSG factory. For example, use "Datum" instead of [Datum] in hard-coded queries (before this commit, [Datum] was replaced by "Datum" at runtime). - posted by de...@apache.org on 2025/06/30 17:05:22 UTC, 0 replies.
- (sis) 04/04: Add enumeration values for new tables and new types introduced in EPSG 10. Update the documentation about the new tables. - posted by de...@apache.org on 2025/06/30 17:05:23 UTC, 0 replies.