You are viewing a plain text version of this content. The canonical link for it is here.
- (lucene) branch branch_9x updated: Don't clone an IndexInput if postings are inlined in the terms dict (#13585). - posted by jp...@apache.org on 2024/08/01 10:54:46 UTC, 0 replies.
- (lucene) branch main updated (47650a4314d -> 0a247698504) - posted by jp...@apache.org on 2024/08/01 10:55:16 UTC, 0 replies.
- (lucene) branch main updated: SparseFixedBitSet#firstDoc: reduce number of `indices` iterations for a bit set that is not fully built yet. (#13559) - posted by gs...@apache.org on 2024/08/01 14:12:03 UTC, 0 replies.
- (lucene) branch main updated: Move CHANGES entry for GH#13559 from 10.0 to 9.12 - posted by gs...@apache.org on 2024/08/01 14:16:07 UTC, 0 replies.
- (lucene) branch main updated: HnswLock: access locks via hash and only use for concurrent indexing (#13581) - posted by so...@apache.org on 2024/08/01 14:23:01 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix lazy decoding of freqs. (#13585) - posted by jp...@apache.org on 2024/08/01 14:25:17 UTC, 0 replies.
- (lucene) branch main updated: Fix lazy decoding of freqs. (#13585) - posted by jp...@apache.org on 2024/08/01 14:25:54 UTC, 0 replies.
- (lucene) branch main updated: Add CHANGES entry for GH-13581 - posted by so...@apache.org on 2024/08/01 14:31:06 UTC, 0 replies.
- (lucene) branch branch_9x updated (adc2361b01d -> 4a93020937b) - posted by so...@apache.org on 2024/08/01 14:31:52 UTC, 0 replies.
- (lucene) 01/02: HnswLock: access locks via hash and only use for concurrent indexing (#13581) - posted by so...@apache.org on 2024/08/01 14:31:53 UTC, 0 replies.
- (lucene) 02/02: Add CHANGES entry for GH-13581 - posted by so...@apache.org on 2024/08/01 14:31:54 UTC, 0 replies.
- (lucene) branch branch_9x updated: SparseFixedBitSet#firstDoc: reduce number of `indices` iterations for a bit set that is not fully built yet. (#13559) - posted by gs...@apache.org on 2024/08/01 14:44:18 UTC, 0 replies.
- (lucene) branch main updated: Revert cosine deprecation (#13613) - posted by be...@apache.org on 2024/08/01 19:05:12 UTC, 0 replies.
- (lucene) branch branch_9x updated: Revert cosine deprecation (#13613) - posted by be...@apache.org on 2024/08/01 19:14:14 UTC, 0 replies.
- (lucene) branch main updated: Remove some BitSet#nextSetBit code duplication (#13625) - posted by gs...@apache.org on 2024/08/02 02:16:46 UTC, 0 replies.
- (lucene) branch main updated (99f35e3f8b7 -> 35a5d7323b8) - posted by gs...@apache.org on 2024/08/02 02:19:53 UTC, 0 replies.
- (lucene) branch branch_9x updated: Remove some BitSet#nextSetBit code duplication (#13625) - posted by gs...@apache.org on 2024/08/02 02:39:58 UTC, 0 replies.
- (lucene) branch main updated: Fix testAddDocumentOnDiskFull to handle IllegalStateException from IndexWriter#close (#13558) - posted by zh...@apache.org on 2024/08/02 07:28:10 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix testAddDocumentOnDiskFull to handle IllegalStateException from IndexWriter#close (#13558) - posted by zh...@apache.org on 2024/08/02 07:42:52 UTC, 0 replies.
- (lucene) branch main updated: Fix failing unit test - TestTopDocsCollector#testResultsOrder (#13621) - posted by jp...@apache.org on 2024/08/02 12:03:15 UTC, 0 replies.
- (lucene) branch main updated (1ce1156de44 -> cb8bc757507) - posted by gs...@apache.org on 2024/08/02 15:12:40 UTC, 0 replies.
- (lucene) branch branch_9x updated: Rename prefix to prefixLength, suffix to suffixLength. (#13629) - posted by gs...@apache.org on 2024/08/02 15:17:24 UTC, 0 replies.
- (lucene) branch main updated: KMeans clustering algorithm (#13604) - posted by ma...@apache.org on 2024/08/02 15:59:21 UTC, 0 replies.
- (lucene) branch main updated: Fix ScalarQuantization when used with COSINE similarity (#13615) - posted by be...@apache.org on 2024/08/05 16:29:20 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix ScalarQuantization when used with COSINE similarity (#13615) - posted by be...@apache.org on 2024/08/05 16:41:19 UTC, 0 replies.
- (lucene) branch main updated: Add timeout support to AbstractVectorSimilarityQuery (#13285) - posted by vi...@apache.org on 2024/08/06 00:12:27 UTC, 0 replies.
- (lucene) branch main updated: Add missing test for Lucene912PostingsFormat. - posted by jp...@apache.org on 2024/08/06 12:33:21 UTC, 0 replies.
- (lucene) branch branch_9x updated: Add missing test for Lucene912PostingsFormat. - posted by jp...@apache.org on 2024/08/06 12:33:45 UTC, 0 replies.
- (lucene) branch branch_9x updated: Tidy. - posted by jp...@apache.org on 2024/08/06 13:01:30 UTC, 0 replies.
- (lucene) branch main updated: Add float|byte vector support to memory index (#13633) - posted by be...@apache.org on 2024/08/07 12:38:46 UTC, 0 replies.
- (lucene) branch branch_9x updated: Add float|byte vector support to memory index (#13633) - posted by be...@apache.org on 2024/08/07 13:41:06 UTC, 0 replies.
- (lucene) branch main updated: Make CandidateMatcher functions public (#13632) - posted by ro...@apache.org on 2024/08/07 14:28:12 UTC, 0 replies.
- (lucene) branch main updated (926d8f4ce63 -> d26b1521170) - posted by be...@apache.org on 2024/08/07 17:31:05 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix race condition on flush for DWPT seqNo generation (#13627) - posted by be...@apache.org on 2024/08/07 17:38:01 UTC, 0 replies.
- (lucene) branch main updated: gh-12627: HnswGraphBuilder connects disconnected HNSW graph components (#13566) - posted by so...@apache.org on 2024/08/08 18:42:00 UTC, 0 replies.
- (lucene) branch main updated: fix TestHnswUtil when top level is disconnected; add CHANGES entry - posted by so...@apache.org on 2024/08/08 23:56:55 UTC, 0 replies.
- (lucene) branch branch_9x updated (a546ed51885 -> 98fbbe2d673) - posted by so...@apache.org on 2024/08/09 00:20:10 UTC, 0 replies.
- (lucene) branch main updated: Knn(Float-->Byte)VectorField javadocs update in KnnByteVectorQuery (#13637) - posted by cp...@apache.org on 2024/08/09 08:44:19 UTC, 0 replies.
- (lucene) branch branch_9x updated: Knn(Float-->Byte)VectorField javadocs update in KnnByteVectorQuery (#13637) - posted by cp...@apache.org on 2024/08/09 08:45:36 UTC, 0 replies.
- (lucene) branch main updated: Get better cost estimate on MultiTermQuery over few terms (#13201) - posted by gs...@apache.org on 2024/08/09 16:16:21 UTC, 0 replies.
- (lucene) branch branch_9x updated: Get better cost estimate on MultiTermQuery over few terms (#13201) - posted by gs...@apache.org on 2024/08/09 17:17:54 UTC, 0 replies.
- (lucene) branch main updated: Minor offset tracking tweak in PointRangeQuery #matches and #relate (#13599) - posted by gs...@apache.org on 2024/08/09 20:50:52 UTC, 0 replies.
- (lucene) branch branch_9x updated: Minor offset tracking tweak in PointRangeQuery #matches and #relate (#13599) - posted by gs...@apache.org on 2024/08/09 21:09:05 UTC, 0 replies.
- (lucene) branch main updated: Two fixes for recently-added HnswGraphBuilder.connectComponents: (#13642) - posted by so...@apache.org on 2024/08/10 20:59:45 UTC, 0 replies.
- (lucene) branch branch_9x updated: Two fixes for recently-added HnswGraphBuilder.connectComponents: - posted by so...@apache.org on 2024/08/10 21:00:35 UTC, 0 replies.
- (lucene) branch main updated: Mark some fields final in Lucene99SkipWriter (#13639) - posted by gs...@apache.org on 2024/08/12 14:06:56 UTC, 0 replies.
- (lucene) branch branch_9x updated: Mark some fields final in Lucene99SkipWriter (#13639) - posted by gs...@apache.org on 2024/08/12 14:13:19 UTC, 0 replies.
- (lucene) branch main updated: Sandbox: Compute facets while collecting (#13568) - posted by gs...@apache.org on 2024/08/12 14:27:04 UTC, 0 replies.
- (lucene) branch main updated (304d4e7855d -> beea8777757) - posted by gs...@apache.org on 2024/08/12 14:31:00 UTC, 0 replies.
- (lucene) branch branch_9x updated: Sandbox: Compute facets while collecting (#13568) - posted by gs...@apache.org on 2024/08/12 17:43:21 UTC, 0 replies.
- (lucene) branch branch_9x updated (f68e74034a7 -> 9bfa91eb905) - posted by gs...@apache.org on 2024/08/12 17:51:25 UTC, 0 replies.
- (lucene) branch main updated: Optimize decoding blocks of postings using the vector API. (#13636) - posted by jp...@apache.org on 2024/08/13 19:49:16 UTC, 0 replies.
- (lucene) branch main updated: Call HnswGraphBuilder.getCompletedGraph() in 94/95 back-compat writers (#13654) - posted by so...@apache.org on 2024/08/14 12:55:29 UTC, 0 replies.
- (lucene) branch branch_9x updated: Call HnswGraphBuilder.getCompletedGraph() in 94/95 back-compat writers - posted by so...@apache.org on 2024/08/14 13:14:31 UTC, 0 replies.
- (lucene) branch main updated: Revert changes to IndexSearcher brought in by GH#13568 (#13656) - posted by gs...@apache.org on 2024/08/14 17:08:14 UTC, 0 replies.
- (lucene) branch branch_9x updated: gh-13653: Call finish() from HnswGraphBuilder.build() (#13655) - posted by so...@apache.org on 2024/08/14 19:06:56 UTC, 0 replies.
- (lucene) branch main updated: Fix eclipse ide settings generation (#13649) - posted by us...@apache.org on 2024/08/14 21:50:11 UTC, 0 replies.
- (lucene) branch main updated: Compare the missing value with the top value even after the hit queue is full (#13644) - posted by gs...@apache.org on 2024/08/14 22:34:01 UTC, 0 replies.
- (lucene) branch branch_9x updated: Compare the missing value with the top value even after the hit queue is full (#13644) - posted by gs...@apache.org on 2024/08/14 22:47:45 UTC, 0 replies.
- (lucene) branch branch_9x updated: Revert changes to IndexSearcher brought in by GH#13568 (#13656) - posted by gs...@apache.org on 2024/08/15 15:05:11 UTC, 0 replies.
- (lucene) branch main updated (7cd2eb20cf9 -> f96caeeb92b) - posted by dw...@apache.org on 2024/08/15 20:29:38 UTC, 0 replies.
- (lucene) 01/02: Fix icu's regeneration script: instead of getVersion we can just pick the version from the catalog. - posted by dw...@apache.org on 2024/08/15 20:29:39 UTC, 0 replies.
- (lucene) 02/02: Update checksums after tidy/ regenerate. - posted by dw...@apache.org on 2024/08/15 20:29:40 UTC, 0 replies.
- (lucene) branch main updated: Revert "Update checksums after tidy/ regenerate." - posted by dw...@apache.org on 2024/08/15 20:31:08 UTC, 0 replies.
- (lucene) branch main updated: Upgrade spotless to 6.9.1, google java format to 1.23.0. (#13661) - posted by dw...@apache.org on 2024/08/16 07:28:51 UTC, 0 replies.
- (lucene) branch branch_9x updated: Optimize decoding blocks of postings using the vector API. (#13636) (#13652) - posted by jp...@apache.org on 2024/08/16 12:52:32 UTC, 0 replies.
- (lucene) branch branch_9x updated: Simplify FSTCompiler loop (#13663) - posted by gs...@apache.org on 2024/08/16 17:44:15 UTC, 0 replies.
- (lucene) branch main updated: Speed up prefix sums when decoding doc IDs. (#13658) - posted by jp...@apache.org on 2024/08/16 19:27:38 UTC, 0 replies.
- (lucene) branch branch_9x updated: Speed up prefix sums when decoding doc IDs. (#13658) - posted by jp...@apache.org on 2024/08/16 19:42:27 UTC, 0 replies.
- (lucene) branch main updated: Only attempt to connect components when entry point is valid (#13660) - posted by be...@apache.org on 2024/08/19 12:36:58 UTC, 0 replies.
- (lucene) branch branch_9x updated: Only attempt to connect components when entry point is valid (#13660) - posted by be...@apache.org on 2024/08/19 12:46:06 UTC, 0 replies.
- (lucene) branch main updated: Modernize switch statements in ArrayUtil (#13669) - posted by gs...@apache.org on 2024/08/19 21:23:40 UTC, 0 replies.
- (lucene) branch main updated: Convert BKDConfig to a record (#13668) - posted by iv...@apache.org on 2024/08/20 09:44:35 UTC, 0 replies.
- (lucene) branch main updated: Display frame types when analyzing top frames. (#13670) - posted by jp...@apache.org on 2024/08/20 21:36:57 UTC, 0 replies.
- (lucene) branch main updated: import definition of default parameter values from o.a.l.util.HnswGraphBuilder (#13674) - posted by so...@apache.org on 2024/08/21 18:06:51 UTC, 0 replies.
- (lucene) branch main updated: Release memory for cancelled tasks earlier in TaskExecutor (#13609) - posted by ab...@apache.org on 2024/08/21 19:25:14 UTC, 0 replies.
- (lucene) branch branch_9x updated: Release memory for cancelled tasks earlier in TaskExecutor (#13609) - posted by ab...@apache.org on 2024/08/21 19:48:12 UTC, 0 replies.
- (lucene) branch main updated: Take advantage of the doc value skipper when it is primary sort (#13592) - posted by iv...@apache.org on 2024/08/22 10:28:31 UTC, 0 replies.
- (lucene) branch main updated: Support JDK 23 in Panama Vectorization Provider (#13678) - posted by ch...@apache.org on 2024/08/22 12:51:37 UTC, 0 replies.
- (lucene) branch branch_9x updated: Support JDK 23 in Panama Vectorization Provider (#13678) - posted by ch...@apache.org on 2024/08/22 13:02:23 UTC, 0 replies.
- (lucene) branch branch_9x updated: [9.x] Aggregate files from the same segment into a single Arena (#13682) - posted by ch...@apache.org on 2024/08/23 14:02:02 UTC, 0 replies.
- (lucene) branch main updated: reconcile changes txt - posted by ch...@apache.org on 2024/08/23 14:04:51 UTC, 0 replies.
- (lucene) branch main updated: Use Max WAND optimizations with ToParentBlockJoinQuery when using ScoreMode.Max (#13587) - posted by jp...@apache.org on 2024/08/26 12:43:54 UTC, 0 replies.
- (lucene) branch branch_9x updated: Use Max WAND optimizations with ToParentBlockJoinQuery when using ScoreMode.Max (#13587) - posted by jp...@apache.org on 2024/08/26 12:54:04 UTC, 0 replies.
- (lucene) branch main updated: Leverage doc value skip lists in DocValuesRewriteMethod if indexed (#13672) - posted by gs...@apache.org on 2024/08/26 17:04:18 UTC, 0 replies.
- (lucene) branch main updated: fixup CHANGES entry for GH#13592 - posted by gs...@apache.org on 2024/08/26 17:30:32 UTC, 0 replies.
- (lucene) branch main updated: move GH#13672 entry under 10.0 - posted by gs...@apache.org on 2024/08/26 17:32:50 UTC, 0 replies.
- (lucene) branch main updated: Edit HNSW API docs (#13688) - posted by so...@apache.org on 2024/08/26 18:18:04 UTC, 0 replies.
- (lucene-solr) branch branch_8_11 updated (1f6bd6cbf80 -> 87b70188c78) - posted by ho...@apache.org on 2024/08/27 20:04:57 UTC, 0 replies.
- (lucene-solr) 01/02: SOLR-17417: Remove unecessary code in PKIAuthPlugin and HttpSolrCall - posted by ho...@apache.org on 2024/08/27 20:04:58 UTC, 0 replies.
- (lucene-solr) 02/02: SOLR-17418: Streamline configSet code - posted by ho...@apache.org on 2024/08/27 20:04:59 UTC, 0 replies.
- (lucene) branch main updated: Fixed exponent value in explain of SigmoidFunction (#13691) - posted by mi...@apache.org on 2024/08/27 20:13:05 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fixed exponent value in explain of SigmoidFunction (#13691) - posted by mi...@apache.org on 2024/08/27 20:18:29 UTC, 0 replies.
- (lucene) branch main updated: Remove mention of SolrNamedThreadFactory (#13690) - posted by vo...@apache.org on 2024/08/28 10:08:03 UTC, 0 replies.
- (lucene) branch branch_9x updated: Remove mention of SolrNamedThreadFactory (#13690) - posted by vo...@apache.org on 2024/08/28 10:27:43 UTC, 0 replies.
- (lucene) branch main updated: adding a few toString methods for HNSW scoring classes (#13694) - posted by mi...@apache.org on 2024/08/28 14:15:46 UTC, 0 replies.
- (lucene) branch branch_9x updated: adding a few toString methods for HNSW scoring classes (#13694) - posted by mi...@apache.org on 2024/08/28 14:20:51 UTC, 0 replies.
- (lucene) branch main updated: Speed up advancing within a block. (#13692) - posted by jp...@apache.org on 2024/08/28 15:31:14 UTC, 0 replies.
- (lucene) branch branch_9x updated: Speed up advancing within a block. (#13692) - posted by jp...@apache.org on 2024/08/28 15:39:54 UTC, 0 replies.
- (lucene) branch main updated: Fix Gradle build sometimes gives spurious "unreferenced license file" warnings (#13696) - posted by us...@apache.org on 2024/08/28 18:35:31 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix Gradle build sometimes gives spurious "unreferenced license file" warnings (#13696) - posted by us...@apache.org on 2024/08/28 18:44:44 UTC, 0 replies.
- (lucene) branch main updated: Udpate ReadTask to not rely on search(Query, Collector) (#13602) - posted by ja...@apache.org on 2024/08/29 08:53:59 UTC, 0 replies.
- (lucene) branch main updated: Upgrade to gradle 8.10 (#13700) - posted by dw...@apache.org on 2024/08/30 10:37:02 UTC, 0 replies.
- (lucene) branch main updated (ea1441c81cc -> 6d373dbb4e5) - posted by ch...@apache.org on 2024/08/30 13:00:39 UTC, 0 replies.
- (lucene) branch main updated: Add jdk 23-ea to nightly smoke tester run. #13700 - posted by dw...@apache.org on 2024/08/30 16:19:55 UTC, 0 replies.