You are viewing a plain text version of this content. The canonical link for it is here.
- (lucene) branch main updated: Make Gradle dashboard easy to find by adding a badge (#13476) - posted by vo...@apache.org on 2024/07/01 08:09:59 UTC, 0 replies.
- (lucene) branch main updated: Remove unused segNo calculation in IndexWriter.doFlush (#13491) - posted by cp...@apache.org on 2024/07/01 16:29:16 UTC, 0 replies.
- (lucene) branch main updated: [Abstract]Knn[Byte|Float]VectorQuery tweaks: reduce duplicate method calls (#13528) - posted by cp...@apache.org on 2024/07/01 16:31:07 UTC, 0 replies.
- (lucene) branch main updated: Lucene99HnswVectorsReader.search float-vs-byte variants: reduce code duplication (#13529) - posted by cp...@apache.org on 2024/07/01 16:32:09 UTC, 0 replies.
- (lucene) branch branch_9x updated (6304105c104 -> 48816b4de42) - posted by cp...@apache.org on 2024/07/01 16:58:13 UTC, 0 replies.
- (lucene) 01/03: Remove unused segNo calculation in IndexWriter.doFlush (#13491) - posted by cp...@apache.org on 2024/07/01 16:58:14 UTC, 0 replies.
- (lucene) 02/03: [Abstract]Knn[Byte|Float]VectorQuery tweaks: reduce duplicate method calls (#13528) - posted by cp...@apache.org on 2024/07/01 16:58:15 UTC, 0 replies.
- (lucene) 03/03: Lucene99HnswVectorsReader.search float-vs-byte variants: reduce code duplication (#13529) - posted by cp...@apache.org on 2024/07/01 16:58:16 UTC, 0 replies.
- (lucene) branch main updated: TaskExecutor should not fork unnecessarily (#13472) - posted by ja...@apache.org on 2024/07/04 09:15:32 UTC, 0 replies.
- (lucene) branch branch_9x updated: TaskExecutor should not fork unnecessarily (#13472) - posted by ja...@apache.org on 2024/07/04 09:59:33 UTC, 0 replies.
- (lucene) branch main updated: Replace AtomicLong with LongAdder in HitsThresholdChecker (#13546) - posted by jp...@apache.org on 2024/07/08 08:52:34 UTC, 0 replies.
- (lucene) branch main updated (2a8d328ab22 -> 675772546c5) - posted by jp...@apache.org on 2024/07/08 08:53:31 UTC, 0 replies.
- (lucene) branch main updated: Override single byte writes to OutputStreamIndexOutput to remove locking (#13543) - posted by jp...@apache.org on 2024/07/08 08:59:56 UTC, 0 replies.
- (lucene) branch branch_9x updated (e78f23738f4 -> 35de1ead82d) - posted by jp...@apache.org on 2024/07/08 09:07:08 UTC, 0 replies.
- (lucene) 01/03: Replace AtomicLong with LongAdder in HitsThresholdChecker (#13546) - posted by jp...@apache.org on 2024/07/08 09:07:09 UTC, 0 replies.
- (lucene) 02/03: Optimize MaxScoreBulkScorer (#13544) - posted by jp...@apache.org on 2024/07/08 09:07:10 UTC, 0 replies.
- (lucene) 03/03: Override single byte writes to OutputStreamIndexOutput to remove locking (#13543) - posted by jp...@apache.org on 2024/07/08 09:07:11 UTC, 0 replies.
- (lucene) branch main updated: Improve VectorUtil::xorBitCount perf on ARM (#13545) - posted by ch...@apache.org on 2024/07/08 16:30:51 UTC, 0 replies.
- (lucene) branch branch_9x updated: Improve VectorUtil::xorBitCount perf on ARM (#13545) - posted by ch...@apache.org on 2024/07/08 16:32:59 UTC, 0 replies.
- (lucene) branch main updated: Refactor and javadoc update for KNN vector writer classes (#13548) - posted by pa...@apache.org on 2024/07/08 20:04:32 UTC, 0 replies.
- (lucene) branch branch_9x updated: Refactor and javadoc update for KNN vector writer classes (#13548) - posted by pa...@apache.org on 2024/07/08 20:05:21 UTC, 0 replies.
- (lucene) branch branch_9x updated: Revert accidentally added file during cherry-pick/merge from main branch (#13545) - posted by us...@apache.org on 2024/07/08 22:51:51 UTC, 0 replies.
- (lucene) branch main updated: Add link to OpenJDK JIRA issue for VectorUtil::xorBitCount - posted by ch...@apache.org on 2024/07/09 11:17:46 UTC, 0 replies.
- (lucene) branch branch_9x updated: Add link to OpenJDK JIRA issue for VectorUtil::xorBitCount - posted by ch...@apache.org on 2024/07/09 11:18:27 UTC, 0 replies.
- (lucene) branch main updated: Introduce TestLucene90DocValuesFormatVariableSkipInterval for testing docvalues skipper index (#13550) - posted by iv...@apache.org on 2024/07/09 13:46:21 UTC, 0 replies.
- (lucene) branch main updated: GITHUB#13175: Stop double-checking priority queue inserts in some FacetCount classes (#13488) - posted by mi...@apache.org on 2024/07/09 14:25:08 UTC, 0 replies.
- (lucene) branch main updated: Fix quantized vector writer ram estimates (#13553) - posted by be...@apache.org on 2024/07/09 17:00:16 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix quantized vector writer ram estimates (#13553) - posted by be...@apache.org on 2024/07/09 17:07:50 UTC, 0 replies.
- (lucene) branch main updated: Lookup next when current doc is deleted in PerThreadPKLookup.lookup (#13556) - posted by jp...@apache.org on 2024/07/10 08:14:19 UTC, 0 replies.
- (lucene) branch branch_9x updated: Lookup next when current doc is deleted in PerThreadPKLookup.lookup (#13556) - posted by jp...@apache.org on 2024/07/10 08:26:12 UTC, 0 replies.
- (lucene) branch main updated: Use a confined Arena for IOContext.READONCE (#13535) - posted by ch...@apache.org on 2024/07/10 08:39:40 UTC, 0 replies.
- (lucene) branch branch_9x updated: GITHUB#13175: Stop double-checking priority queue inserts in some FacetCount classes (#13488) - posted by mi...@apache.org on 2024/07/10 11:35:04 UTC, 0 replies.
- (lucene) branch main updated: Use `IndexInput#prefetch` for terms dictionary lookups. (#13359) - posted by jp...@apache.org on 2024/07/10 13:36:40 UTC, 0 replies.
- (lucene) branch branch_9x updated: [9.x] Use a confined Arena for IOContext.READONCE (#13535) (#13560) - posted by ch...@apache.org on 2024/07/10 13:51:31 UTC, 0 replies.
- (lucene) branch main updated: Reduce heap usage for knn index writers (#13538) - posted by be...@apache.org on 2024/07/10 14:28:53 UTC, 0 replies.
- (lucene) branch main updated: Minor cleanup in some Facet tests (#13489) - posted by vo...@apache.org on 2024/07/10 16:05:14 UTC, 0 replies.
- (lucene) branch branch_9x updated: Minor cleanup in some Facet tests (#13489) - posted by vo...@apache.org on 2024/07/10 16:33:02 UTC, 0 replies.
- (lucene) branch branch_9x updated: Reduce heap usage for knn index writers (#13538) - posted by be...@apache.org on 2024/07/10 17:02:44 UTC, 0 replies.
- (lucene) branch main updated: WordBreakSpellChecker.suggestWordBreaks now does a breadth first search (#12100) - posted by ho...@apache.org on 2024/07/10 18:07:44 UTC, 0 replies.
- (lucene) branch branch_9x updated: WordBreakSpellChecker.suggestWordBreaks now does a breadth first search (#12100) - posted by ho...@apache.org on 2024/07/10 18:26:07 UTC, 0 replies.
- (lucene) branch main updated: Add HnswGraphBuilder.getCompletedGraph() and record completed state (#13561) - posted by so...@apache.org on 2024/07/11 15:44:55 UTC, 0 replies.
- (lucene) branch main updated: Lucene99HnswVectorsReader[.readFields] readability tweaks (#13532) - posted by cp...@apache.org on 2024/07/12 08:49:38 UTC, 0 replies.
- (lucene) branch branch_9x updated: Lucene99HnswVectorsReader[.readFields] readability tweaks (#13532) - posted by cp...@apache.org on 2024/07/12 08:50:42 UTC, 0 replies.
- (lucene) branch main updated: in KnnVectorsWriter reduce code duplication w.r.t. MergedVectorValues.merge(Float|Byte)VectorValues (#13539) - posted by cp...@apache.org on 2024/07/12 09:48:16 UTC, 0 replies.
- (lucene) branch branch_9x updated: in KnnVectorsWriter reduce code duplication w.r.t. MergedVectorValues.merge(Float|Byte)VectorValues (#13539) - posted by cp...@apache.org on 2024/07/12 09:57:58 UTC, 0 replies.
- (lucene) branch main updated: Add IntervalsSource for range and regexp queries (#13562) - posted by ma...@apache.org on 2024/07/14 13:48:23 UTC, 0 replies.
- (lucene) branch branch_9x updated: Add IntervalsSource for range and regexp queries (#13569) - posted by ma...@apache.org on 2024/07/15 15:04:51 UTC, 0 replies.
- (lucene) branch main updated: Ensure to use IOContext.READONCE when reading segment files (#13574) - posted by ch...@apache.org on 2024/07/17 07:56:17 UTC, 0 replies.
- (lucene) branch main updated (99488b22455 -> 22ca695ef5c) - posted by jp...@apache.org on 2024/07/17 11:54:25 UTC, 0 replies.
- (lucene) branch branch_9x updated: Add target search concurrency to TieredMergePolicy (#13430) - posted by jp...@apache.org on 2024/07/17 12:10:14 UTC, 0 replies.
- (lucene) branch branch_9x updated: [9.x] Ensure to use IOContext.READONCE when reading segment files (#13578) - posted by ch...@apache.org on 2024/07/17 13:32:00 UTC, 0 replies.
- (lucene) branch main updated: Stop requiring MaxScoreBulkScorer's outer window from having at least INNER_WINDOW_SIZE docs. (#13582) - posted by jp...@apache.org on 2024/07/18 09:23:26 UTC, 0 replies.
- (lucene) branch main updated (fff997f8016 -> 9f040864a62) - posted by jp...@apache.org on 2024/07/18 09:28:41 UTC, 0 replies.
- (lucene) branch branch_9x updated (b2d3a2b37e0 -> bbcd65fa913) - posted by jp...@apache.org on 2024/07/18 10:05:37 UTC, 0 replies.
- (lucene) 01/02: Stop requiring MaxScoreBulkScorer's outer window from having at least INNER_WINDOW_SIZE docs. (#13582) - posted by jp...@apache.org on 2024/07/18 10:05:38 UTC, 0 replies.
- (lucene) 02/02: Add a `targetSearchConcurrency` parameter to `LogMergePolicy`. (#13517) - posted by jp...@apache.org on 2024/07/18 10:05:39 UTC, 0 replies.
- (lucene) branch main updated (9f040864a62 -> 00c9d9a03c9) - posted by jp...@apache.org on 2024/07/18 10:07:51 UTC, 0 replies.
- (lucene) branch soft-deletes-wrapper created (now 2c681312655) - posted by dn...@apache.org on 2024/07/18 21:23:43 UTC, 0 replies.
- (lucene) 01/01: Avoid wrap readers without soft-deletes - posted by dn...@apache.org on 2024/07/18 21:23:44 UTC, 1 replies.
- (lucene) branch soft-deletes-wrapper updated (2c681312655 -> 8e8adb1611f) - posted by dn...@apache.org on 2024/07/18 21:32:18 UTC, 0 replies.
- (lucene) branch main updated (00c9d9a03c9 -> b42fd8e479c) - posted by dn...@apache.org on 2024/07/19 05:47:50 UTC, 0 replies.
- (lucene) branch soft-deletes-wrapper deleted (was 8e8adb1611f) - posted by dn...@apache.org on 2024/07/19 05:48:47 UTC, 0 replies.
- (lucene) branch 9x-lucene-13588 created (now d4dcf37d70b) - posted by dn...@apache.org on 2024/07/19 05:49:02 UTC, 0 replies.
- (lucene) 01/01: Avoid wrap readers without soft-deletes (#13588) - posted by dn...@apache.org on 2024/07/19 05:49:03 UTC, 1 replies.
- (lucene) branch backport-9-11-wrap-readers created (now 218cf73bb74) - posted by dn...@apache.org on 2024/07/19 05:52:34 UTC, 0 replies.
- (lucene) branch branch_9_11 updated: Avoid wrap readers without soft-deletes (#13588) (#13591) - posted by dn...@apache.org on 2024/07/19 06:36:17 UTC, 0 replies.
- (lucene) branch backport-9-11-wrap-readers deleted (was 218cf73bb74) - posted by dn...@apache.org on 2024/07/19 06:36:21 UTC, 0 replies.
- (lucene) branch branch_9x updated: Avoid wrap readers without soft-deletes (#13588) (#13590) - posted by dn...@apache.org on 2024/07/19 06:36:36 UTC, 0 replies.
- (lucene) branch 9x-lucene-13588 deleted (was d4dcf37d70b) - posted by dn...@apache.org on 2024/07/19 06:36:40 UTC, 0 replies.
- (lucene) branch main updated: Remove useless todo. (#13589) - posted by jp...@apache.org on 2024/07/19 08:12:57 UTC, 0 replies.
- (lucene) branch main updated (c245ed2fb45 -> 9f991ed07e1) - posted by iv...@apache.org on 2024/07/19 09:20:23 UTC, 0 replies.
- (lucene) branch main updated (9f991ed07e1 -> cc3b412183c) - posted by jp...@apache.org on 2024/07/19 13:18:33 UTC, 0 replies.
- (lucene) branch main updated (cc3b412183c -> 7709f575efe) - posted by iv...@apache.org on 2024/07/22 12:52:51 UTC, 0 replies.
- (lucene) branch main updated (7709f575efe -> 1c3925cb150) - posted by mi...@apache.org on 2024/07/22 15:37:10 UTC, 0 replies.
- (lucene) branch main updated: Add simple tool to diff entries in lucene's CHANGES.txt that should be identical (#12860) - posted by mi...@apache.org on 2024/07/22 15:37:39 UTC, 0 replies.
- (lucene) branch main updated: Refactor FST.saveMetadata() to FSTMetadata.save() (#13549) - posted by mi...@apache.org on 2024/07/22 16:14:58 UTC, 0 replies.
- (lucene) branch branch_9x updated: Refactor FST.saveMetadata() to FSTMetadata.save() (#13549) - posted by mi...@apache.org on 2024/07/23 11:15:09 UTC, 0 replies.
- (lucene) branch main updated (97d89c661f9 -> d491dfe1315) - posted by ja...@apache.org on 2024/07/24 11:06:37 UTC, 0 replies.
- (lucene) branch main updated (d491dfe1315 -> 97d066dd6b0) - posted by ja...@apache.org on 2024/07/24 11:07:12 UTC, 0 replies.
- (lucene) branch branch_9x updated (c23f6c09f7d -> 9d663c5939b) - posted by ja...@apache.org on 2024/07/24 11:34:04 UTC, 0 replies.
- (lucene) 01/02: Update TestTopDocsCollector to no longer rely on the deprecated search(Query, Collector) (#13600) - posted by ja...@apache.org on 2024/07/24 11:34:05 UTC, 0 replies.
- (lucene) 02/02: Update TestTopDocsMerge to not rely on search(Query, Collector) (#13601) - posted by ja...@apache.org on 2024/07/24 11:34:06 UTC, 0 replies.
- (lucene) branch main updated: Further reduce the search concurrency overhead. (#13606) - posted by jp...@apache.org on 2024/07/24 12:58:59 UTC, 0 replies.
- (lucene) branch branch_9x updated (9d663c5939b -> 6beebfb6990) - posted by jp...@apache.org on 2024/07/24 13:19:34 UTC, 0 replies.
- (lucene) 01/02: Fix test failure - posted by jp...@apache.org on 2024/07/24 13:19:35 UTC, 0 replies.
- (lucene) 02/02: Further reduce the search concurrency overhead. (#13606) - posted by jp...@apache.org on 2024/07/24 13:19:36 UTC, 0 replies.
- (lucene) branch branch_9x updated: [9.x] Do not randomize readOnce contexts (#13607) - posted by ch...@apache.org on 2024/07/24 17:43:03 UTC, 0 replies.
- (lucene) branch main updated (acbd7141404 -> 4c1d50d8e8c) - posted by us...@apache.org on 2024/07/24 19:53:35 UTC, 0 replies.
- (lucene) branch branch_9x updated: Save allocating some zero length byte arrays (#13608) - posted by us...@apache.org on 2024/07/24 19:58:32 UTC, 0 replies.
- (lucene) branch main updated: Aggregate files from the same segment into a single Arena (#13570) - posted by ch...@apache.org on 2024/07/25 09:12:09 UTC, 0 replies.
- (lucene) branch main updated: Bump the window size of disjunction from 2,048 to 4,096. (#13605) - posted by jp...@apache.org on 2024/07/25 13:38:26 UTC, 0 replies.
- (lucene) branch main updated: hunspell: add Suggester#proceedPastRep to avoid losing relevant suggestions (#13612) - posted by do...@apache.org on 2024/07/27 19:39:06 UTC, 0 replies.
- (lucene) branch branch_9x updated: hunspell: add Suggester#proceedPastRep to avoid losing relevant suggestions (#13612) - posted by do...@apache.org on 2024/07/27 19:49:33 UTC, 0 replies.
- (lucene) branch main updated: Remove usage of TopScoreDocCollector + TopFieldCollector deprecated methods (#create, #createSharedManager) (#13500) - posted by ja...@apache.org on 2024/07/29 09:06:02 UTC, 0 replies.
- (lucene) branch main updated: Removing all deprecated TopScoreDocCollector + TopFieldCollector methods (#create, #createSharedManager) (#13617) - posted by ja...@apache.org on 2024/07/30 09:33:22 UTC, 0 replies.
- (lucene) branch main updated: Move changes entry for #13499 to API changes - posted by ja...@apache.org on 2024/07/30 09:36:56 UTC, 0 replies.
- (lucene) branch main updated: Introduce IndexSearcher#searchLeaf(LeafReaderContext, Weight, Collector) method (#13603) - posted by ja...@apache.org on 2024/07/30 15:17:32 UTC, 0 replies.
- (lucene) branch branch_9x updated: Introduce IndexSearcher#searchLeaf(LeafReaderContext, Weight, Collector) method (#13603) - posted by ja...@apache.org on 2024/07/30 15:50:20 UTC, 0 replies.
- (lucene) branch main updated: Add test that the default codec parallelizes I/O. (#13579) - posted by jp...@apache.org on 2024/07/31 15:11:50 UTC, 0 replies.
- (lucene) branch main updated (5226e282b4d -> b4a8810b7ae) - posted by jp...@apache.org on 2024/07/31 15:18:34 UTC, 0 replies.
- (lucene) branch branch_9x updated (539274f4530 -> 59b7c28eb47) - posted by jp...@apache.org on 2024/07/31 16:12:25 UTC, 0 replies.
- (lucene) 01/02: Bump the window size of disjunction from 2,048 to 4,096. (#13605) - posted by jp...@apache.org on 2024/07/31 16:12:26 UTC, 0 replies.
- (lucene) 02/02: Inline skip data into postings lists (#13585) - posted by jp...@apache.org on 2024/07/31 16:12:27 UTC, 0 replies.
- (lucene) branch main updated: Wrap Executor in TaskExecutor to never reject (#13622) - posted by ab...@apache.org on 2024/07/31 17:34:40 UTC, 0 replies.
- (lucene) branch main updated: Fix comments containing 'the this' (#13624) - posted by gs...@apache.org on 2024/07/31 18:00:39 UTC, 0 replies.
- (lucene) branch branch_9x updated: Wrap Executor in TaskExecutor to never reject (#13622) - posted by ab...@apache.org on 2024/07/31 18:09:29 UTC, 0 replies.
- (lucene) branch main updated: Deduplicate bytes for `FieldReader#rootCode` (#13610) - posted by ab...@apache.org on 2024/07/31 18:31:19 UTC, 0 replies.
- (lucene) branch branch_9x updated: Deduplicate bytes for `FieldReader#rootCode` (#13610) - posted by ab...@apache.org on 2024/07/31 18:35:50 UTC, 0 replies.
- (lucene) branch branch_9x updated: Fix comments containing 'the this' (#13624) - posted by gs...@apache.org on 2024/07/31 18:37:21 UTC, 0 replies.
- (lucene) branch main updated: Deduplicate min and max term in single-term FieldReader (#13618) - posted by ab...@apache.org on 2024/07/31 18:38:27 UTC, 0 replies.
- (lucene) branch branch_9x updated: Deduplicate min and max term in single-term FieldReader (#13618) - posted by ab...@apache.org on 2024/07/31 18:46:36 UTC, 0 replies.