You are viewing a plain text version of this content. The canonical link for it is here.
- (sis) branch geoapi-3.1 updated (269d8e9759 -> 51124b9153) - posted by de...@apache.org on 2024/06/01 10:54:49 UTC, 0 replies.
- (sis) 01/02: Merge branch 'geoapi-4.0' into geoapi-3.1. The main work is a generalization from `Instant` to `Temporal`. - posted by de...@apache.org on 2024/06/01 10:54:50 UTC, 0 replies.
- (sis) 02/02: Change the `serialVersionUID` of `DefaultCitation` because the following properties are of different types: - citedResponsibleParties (Collection instead of Collection) - otherCitationDetails (InternationalString instead of Collection) - posted by de...@apache.org on 2024/06/01 10:54:51 UTC, 0 replies.
- (sis) branch main updated (c1009799e7 -> 6e63051a6f) - posted by de...@apache.org on 2024/06/01 10:55:16 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1' - posted by de...@apache.org on 2024/06/01 10:55:17 UTC, 1 replies.
- (sis) branch geoapi-4.0 updated: More replacements of `java.util.Date` by `java.time` in metadata. - posted by de...@apache.org on 2024/06/06 17:52:56 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (51124b9153 -> 06e105fa45) - posted by de...@apache.org on 2024/06/07 08:40:07 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1. - posted by de...@apache.org on 2024/06/07 08:40:08 UTC, 0 replies.
- (sis) branch main updated (6e63051a6f -> d4690f7f41) - posted by de...@apache.org on 2024/06/07 10:34:51 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1'. - posted by de...@apache.org on 2024/06/07 10:34:52 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Post-merge import reorganization. - posted by de...@apache.org on 2024/06/07 11:08:30 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (06e105fa45 -> e9dd6d1621) - posted by de...@apache.org on 2024/06/07 11:14:19 UTC, 0 replies.
- (sis) 01/01: Post-merge import reorganization on the geoapi-3.1 branch. - posted by de...@apache.org on 2024/06/07 11:14:20 UTC, 0 replies.
- (sis) branch main updated (d4690f7f41 -> bb9d125402) - posted by de...@apache.org on 2024/06/07 11:17:32 UTC, 0 replies.
- (sis) 01/01: Post-merge imports reorganization on the main branch. - posted by de...@apache.org on 2024/06/07 11:17:33 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Reintroduce `org.opengis.temporal.Instant` from ISO 19108, because this is not the same thing as `java.time.Instant` despite the name. Regroup all temporal objects in an `org.apache.sis.temporal` package, not exported for now. - posted by de...@apache.org on 2024/06/12 15:28:21 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (f2faacb692 -> 90c0f789d7) - posted by de...@apache.org on 2024/06/13 14:14:53 UTC, 0 replies.
- (sis) 01/02: Move `TimeMethods` to `org.apache.sis.temporal` for allowing its use in the implementation of `DefaultInstant.findRelativePosition(TemporalPrimitive)`. - posted by de...@apache.org on 2024/06/13 14:14:54 UTC, 0 replies.
- (sis) 02/02: Rename `StandardDateFormat` as `LenientDateFormat`. - posted by de...@apache.org on 2024/06/13 14:14:55 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (90c0f789d7 -> 06a582ccd0) - posted by de...@apache.org on 2024/06/13 16:59:05 UTC, 0 replies.
- (sis) 01/02: Add a `GeneralDuration.parse(CharSequence)` method. Add more factory methods. - posted by de...@apache.org on 2024/06/13 16:59:06 UTC, 0 replies.
- (sis) 02/02: Rename `TemporalUtilities` as `TemporalObjects`. - posted by de...@apache.org on 2024/06/13 16:59:07 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Fix shapefile index offset and length in incorrect unit - posted by js...@apache.org on 2024/06/14 07:44:11 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Allow the association of GML identifiers to temporal object. It requires making temporal objects lenient comparable. - posted by de...@apache.org on 2024/06/14 12:44:28 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (c1c5e12061 -> e50aa45469) - posted by js...@apache.org on 2024/06/14 14:40:32 UTC, 0 replies.
- (sis) 01/02: Add SQL Dialect supportsReadOnlyUpdate flag, not supported by SQLite - posted by js...@apache.org on 2024/06/14 14:40:33 UTC, 0 replies.
- (sis) 02/02: Add support for gpkg geometry header detection and parsing - posted by js...@apache.org on 2024/06/14 14:40:34 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Formatting and bug fix in the setting of the buffer limit and the use of the Geopackage SRID. - posted by de...@apache.org on 2024/06/15 18:23:45 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (e520c8b28d -> 0edda0c161) - posted by de...@apache.org on 2024/06/16 19:49:49 UTC, 0 replies.
- (sis) 01/02: Actually, `GeometryGetter` does not need to invoke `ByteBuffer.slice()` because WKB readers should start reading from current buffer position. - posted by de...@apache.org on 2024/06/16 19:49:50 UTC, 0 replies.
- (sis) 02/02: Implements `DefaultPeriod.findRelativePosition()`. - posted by de...@apache.org on 2024/06/16 19:49:51 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Delegate `AxisDirections.opposite(…)` to the GeoAPI method. - posted by de...@apache.org on 2024/06/23 16:16:41 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (e9dd6d1621 -> f358804252) - posted by de...@apache.org on 2024/06/23 18:34:54 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1 - Completion of the work on temporal objects - Some work on Shapefile and SQL store - posted by de...@apache.org on 2024/06/23 18:34:55 UTC, 0 replies.
- (sis) branch main updated (bb9d125402 -> 86b20ccbda) - posted by de...@apache.org on 2024/06/23 22:03:23 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Fix shapefile DBF field parsing, tolerate character patterns as missing number values - posted by js...@apache.org on 2024/06/25 10:03:28 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: `ControlledVocabulary.identifier()` become optional. This change helped to see potential NullPointerException. - posted by de...@apache.org on 2024/06/25 14:09:14 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Consolidation in the way to get or create `OperationMethod`: - No longer specify the number of dimensions in constructor. - Search of predefined instance based only on `MathTransformFactory`, using a convenience method added in `ReferencingFactoryContainer`. - posted by de...@apache.org on 2024/06/25 16:26:58 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (f358804252 -> b22144ecf8) - posted by de...@apache.org on 2024/06/25 17:26:45 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1 - posted by de...@apache.org on 2024/06/25 17:26:46 UTC, 0 replies.
- (sis-site) branch main updated (066cfb0b -> 373b0d3e) - posted by de...@apache.org on 2024/06/27 13:54:42 UTC, 0 replies.
- (sis-site) 01/01: Merge pull request #3 from raboof/patch-1 - posted by de...@apache.org on 2024/06/27 13:54:43 UTC, 0 replies.
- (sis-site) branch asf-staging updated: Fix DOAP syntax (port of pull request #3) https://issues.apache.org/jira/browse/INFRA-25892 - posted by de...@apache.org on 2024/06/27 14:05:29 UTC, 0 replies.
- (sis-site) branch asf-site updated (d9e86421 -> 3da99470) - posted by de...@apache.org on 2024/06/27 14:06:38 UTC, 0 replies.
- (sis-site) 01/01: Merge branch 'asf-staging' into asf-site: fix of DOAP syntax. - posted by de...@apache.org on 2024/06/27 14:06:39 UTC, 0 replies.
- (sis) branch geoapi-3.1 updated (b22144ecf8 -> 1930d30455) - posted by de...@apache.org on 2024/06/28 04:09:30 UTC, 0 replies.
- (sis) 01/02: Partial revert of the previous merge: the `CodeList.identifier()` method already existed in GeoAPI 3.0, we cannot change its return type (from `String` to `Optional`) in GeoAPI 3.1. - posted by de...@apache.org on 2024/06/28 04:09:31 UTC, 0 replies.
- (sis) 02/02: Make consistent with the `main` branch. - posted by de...@apache.org on 2024/06/28 04:09:32 UTC, 0 replies.
- (sis) branch main updated (86b20ccbda -> 975aed6c18) - posted by de...@apache.org on 2024/06/28 04:09:51 UTC, 0 replies.
- (sis) 01/01: Merge branch 'geoapi-3.1' - Consolidation in the way to get or create `OperationMethod` - Fix in shapefile DBF field parsing - posted by de...@apache.org on 2024/06/28 04:09:52 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated (6011e9f39f -> 114689a6d6) - posted by js...@apache.org on 2024/06/28 09:16:32 UTC, 0 replies.
- (sis) 01/02: Add hard override of CRS:84 WKT in shapefile prj until we find the problematic WKT element preventing loading in other tools - posted by js...@apache.org on 2024/06/28 09:16:33 UTC, 0 replies.
- (sis) 02/02: Use Uppercase field type notation in DBF, much better understood by other tools - posted by js...@apache.org on 2024/06/28 09:16:34 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Add an implementation of `RegisterOperations` (a new interface added in ISO 19111:2019). - posted by de...@apache.org on 2024/06/28 18:20:40 UTC, 0 replies.
- (sis) branch geoapi-4.0 updated: Deprecate `DefaultMathTransformFactory.createParameterizedTransform(ParameterValueGroup, Context)`. This is replaced by a builder. - posted by de...@apache.org on 2024/06/30 03:19:14 UTC, 0 replies.