You are viewing a plain text version of this content. The canonical link for it is here.
- [jira] [Commented] (HTTPCLIENT-2310) Async client incorrectly pipes CONNECT requests through the main request protocol chain - posted by "Marian (Jira)" <ji...@apache.org> on 2023/12/01 08:33:00 UTC, 1 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.2.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/01 11:37:35 UTC, 0 replies.
- [PR] Bump actions/setup-java from 3 to 4 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/01 13:25:26 UTC, 2 replies.
- Re: [PR] Enforce Support for UTF-8 Encoding Scheme in Digest Authentication as per RFC 7616 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/01 18:55:47 UTC, 3 replies.
- Re: [PR] HTTPCLIENT-2310: Async Connect exec handler incorrectly pipes CONNECT requests through the main request protocol chain [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/02 10:31:43 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2310) Async client incorrectly pipes CONNECT requests through the main request protocol chain - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/02 10:34:00 UTC, 0 replies.
- Re: [PR] Implement Support for Userhash Parameter in Digest Authentication as per RFC 7616 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/02 11:30:46 UTC, 2 replies.
- HttpClient 5.3 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/02 14:52:35 UTC, 2 replies.
- [VOTE] Release HttpClient 5.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/03 09:42:09 UTC, 5 replies.
- Re: [PR] Add validation to prevent both 'username' and 'username*' in DigestScheme headers. [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/03 09:57:57 UTC, 3 replies.
- Re: [PR] Implement username* validation and decoding in DigestScheme [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/03 10:01:22 UTC, 6 replies.
- [jira] [Commented] (HTTPCLIENT-2292) SOCKS proxy configuration is not working - posted by "Daniel Krämer (Jira)" <ji...@apache.org> on 2023/12/03 13:35:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-746) Deadlock with Java Virtual Threads - posted by "Konstantinos Liakos (Jira)" <ji...@apache.org> on 2023/12/03 15:53:00 UTC, 6 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.2.4 GA released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/04 09:55:43 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.2.3 GA Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/04 10:08:21 UTC, 0 replies.
- [jira] [Created] (HTTPASYNC-170) I/O Dispatch Worker terminated abnormally - posted by "Prakash (Jira)" <ji...@apache.org> on 2023/12/05 08:11:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPASYNC-170) I/O Dispatch Worker terminated abnormally - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/05 08:33:00 UTC, 0 replies.
- [jira] [Commented] (HTTPASYNC-170) I/O Dispatch Worker terminated abnormally - posted by "Prakash (Jira)" <ji...@apache.org> on 2023/12/05 08:51:00 UTC, 1 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.3 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/06 08:09:15 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.3 GA Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/07 15:48:18 UTC, 0 replies.
- [PR] Bump log4j.version from 2.20.0 to 2.22.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/08 13:37:02 UTC, 1 replies.
- [VOTE] HttpAsycClient 4.1 and HttpCore NIO 4.4 End of Life / End of Support - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/08 14:10:43 UTC, 5 replies.
- [PR] Support for percent coding as defined in RFC 5987 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/08 18:01:04 UTC, 1 replies.
- [PR] Fix: HTTP response content being truncated to a maximum length of 256 bytes [httpcomponents-client] - posted by "Demonese (via GitHub)" <gi...@apache.org> on 2023/12/09 05:14:28 UTC, 4 replies.
- [PR] Prevent NullPointerException being thrown when constructing log message [httpcomponents-client] - posted by "topbadger (via GitHub)" <gi...@apache.org> on 2023/12/09 18:58:42 UTC, 2 replies.
- [jira] [Created] (HTTPCLIENT-2312) Response body from returnContent() truncated to 256 bytes - posted by "Frank Schimmel (Jira)" <ji...@apache.org> on 2023/12/10 08:48:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2312) Response body from returnContent() truncated to 256 bytes - posted by "Frank Schimmel (Jira)" <ji...@apache.org> on 2023/12/10 08:49:00 UTC, 2 replies.
- [PR] HTTPCLIENT-2312Fix Response Body Truncation Issue in ContentResponseHandler [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/12/11 11:02:48 UTC, 2 replies.
- [jira] [Resolved] (HTTPCLIENT-2312) Response body from returnContent() truncated to 256 bytes - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/11 11:28:00 UTC, 0 replies.
- Re: [PR] HTTPCORE-761: support ExtendedSocketOption in socket [httpcomponents-core] - posted by "kkewwei (via GitHub)" <gi...@apache.org> on 2023/12/12 03:56:09 UTC, 0 replies.
- [VOTE][RESULT] HttpAsycClient 4.1 and HttpCore NIO 4.4 End of Life / End of Support - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/12 09:54:51 UTC, 0 replies.
- HttpCore and HttpClient development and stable branch switch - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/12 14:47:10 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-756) HttpCore HTTP Semantics conformance to RFC 9110 - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/12/13 08:24:00 UTC, 55 replies.
- [jira] [Commented] (HTTPCORE-759) Content-Length missing on null entity request content - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/12/13 08:24:00 UTC, 3 replies.
- [jira] [Commented] (HTTPCLIENT-2277) HttpClient Cache conformance to RFC 9111 - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/12/13 11:00:00 UTC, 19 replies.
- [jira] [Commented] (HTTPCLIENT-2293) HttpClient HTTP Semantics conformance to RFC 9110 - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/12/13 11:00:00 UTC, 10 replies.
- [jira] [Commented] (HTTPCLIENT-2301) BasicHttpClientConnectionManager returns response of previous requests - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/12/13 11:00:00 UTC, 3 replies.
- Re: [PR] Implement HappyEyeballsV2AsyncClientConnectionOperator [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 11:22:04 UTC, 1 replies.
- Re: [PR] Add Zstd support to ContentCompressionExec. [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 11:22:28 UTC, 2 replies.
- Re: [PR] Bump actions/checkout from 3 to 4 [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 11:23:30 UTC, 3 replies.
- Re: [PR] Bump actions/checkout from 3 to 4 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 11:24:27 UTC, 1 replies.
- Re: [PR] Bump org.junit:junit-bom from 5.9.3 to 5.10.0 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 11:25:29 UTC, 2 replies.
- Re: [PR] Bump log4j.version from 2.19.0 to 2.20.0 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 11:25:46 UTC, 2 replies.
- [PR] Bump org.junit:junit-bom from 5.9.1 to 5.10.1 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/13 11:25:51 UTC, 1 replies.
- [PR] Bump log4j.version from 2.19.0 to 2.22.0 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/13 11:26:07 UTC, 1 replies.
- Re: [PR] Bump io.reactivex.rxjava3:rxjava from 3.1.6 to 3.1.8 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 12:24:11 UTC, 1 replies.
- Re: [PR] Bump io.fabric8:docker-maven-plugin from 0.31.0 to 0.43.4 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/13 12:24:45 UTC, 1 replies.
- JDK 22 Feature Freeze! - posted by David Delabassee <da...@oracle.com> on 2023/12/13 14:09:55 UTC, 0 replies.
- HttpCore 5.3 alpha1 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/14 10:52:45 UTC, 2 replies.
- [PR] Bump jna.version from 5.13.0 to 5.14.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 13:37:36 UTC, 2 replies.
- [PR] Bump httpcore.version from 5.2.2 to 5.2.4 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 13:37:49 UTC, 2 replies.
- [PR] Bump org.junit:junit-bom from 5.9.3 to 5.10.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 13:37:59 UTC, 1 replies.
- [PR] Bump com.googlecode.maven-download-plugin:download-maven-plugin from 1.6.8 to 1.7.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 13:38:09 UTC, 1 replies.
- [VOTE] Release HttpCore 5.3-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/15 13:38:36 UTC, 4 replies.
- [PR] Bump github/codeql-action from 2 to 3 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 13:46:15 UTC, 1 replies.
- [PR] Bump actions/setup-java from 3 to 4 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 14:16:13 UTC, 1 replies.
- [PR] Bump commons-cli:commons-cli from 1.5.0 to 1.6.0 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 14:16:21 UTC, 0 replies.
- [PR] Bump github/codeql-action from 2 to 3 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/15 14:16:26 UTC, 1 replies.
- Release called off; Re: [VOTE] Release HttpCore 5.3-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/17 12:26:21 UTC, 3 replies.
- [jira] [Created] (HTTPCLIENT-2313) NPE NullPointerException in PoolingHttpClientConnectionManager when debug logging is enabled - posted by "Sven Haster (Jira)" <ji...@apache.org> on 2023/12/19 09:06:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2313) NPE NullPointerException in PoolingHttpClientConnectionManager when debug logging is enabled - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/19 09:40:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2313) NPE NullPointerException in PoolingHttpClientConnectionManager when debug logging is enabled - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/19 09:41:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2313) NPE NullPointerException in PoolingHttpClientConnectionManager when debug logging is enabled - posted by "Sven Haster (Jira)" <ji...@apache.org> on 2023/12/19 12:42:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2313) NPE NullPointerException in PoolingHttpClientConnectionManager when debug logging is enabled - posted by "Sven Haster (Jira)" <ji...@apache.org> on 2023/12/19 12:42:00 UTC, 0 replies.
- [PR] fix: URIBuilder.getFirstQueryParam throws exception when query is emty [httpcomponents-core] - posted by "skssxf (via GitHub)" <gi...@apache.org> on 2023/12/19 13:03:52 UTC, 4 replies.
- Re: [PR] HTTPCORE-756 - Deprecation of userInfo in Compliance with RFC 9110 [httpcomponents-core] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/19 13:38:39 UTC, 7 replies.
- [VOTE] Release HttpCore 5.3-alpha1 based on RC2 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/20 18:01:12 UTC, 6 replies.
- Meet our keynote speakers and register to Community Over Code EU! - posted by Ryan Skraba <rs...@apache.org> on 2023/12/22 15:47:59 UTC, 0 replies.
- [PR] Implement HappyEyeballsV2AsyncClientConnectionOperator [httpcomponents-client] - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/12/23 06:21:05 UTC, 0 replies.
- [VOTE][RESULT] Release HttpComponents HttpCore 5.3-alpha1 based on RC2 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/23 09:20:04 UTC, 0 replies.
- HttpClient 5.4-alpha1 release notes - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/24 06:26:10 UTC, 1 replies.
- [PR] Regression: incorrect hash calculation (missing realm component) [httpcomponents-client] - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/12/24 16:01:09 UTC, 3 replies.
- [ANNOUNCEMENT] HttpComponents Core 5.3-alpha1 released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/26 14:11:03 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-755) Connection gets closed prematurely before Decoder gets completed - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/26 14:16:00 UTC, 0 replies.
- [VOTE] Release HttpClient 5.4-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/26 14:42:04 UTC, 4 replies.
- [VOTE][RESULT] Release HttpComponents HttpClient 5.4-alpha1 based on RC1 - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/29 09:38:30 UTC, 0 replies.
- [PR] Bump log4j.version from 2.22.0 to 2.22.1 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/29 13:50:41 UTC, 0 replies.
- [PR] Bump com.googlecode.maven-download-plugin:download-maven-plugin from 1.7.1 to 1.8.0 [httpcomponents-client] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/29 13:50:48 UTC, 0 replies.
- [PR] Bump log4j.version from 2.22.0 to 2.22.1 [httpcomponents-core] - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/12/29 14:07:38 UTC, 0 replies.
- [ANNOUNCEMENT] HttpComponents Client 5.4-alpha1 Released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/12/30 07:58:39 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2296) Provide GitHub source links per component - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 08:55:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-1625) Completely overhaul GSS-API-based authentication backend - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 08:58:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2159) Invalid handling of charset content type parameter - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:01:00 UTC, 1 replies.
- [jira] [Updated] (HTTPCLIENT-2070) BasicAuthCache not to use object serialization - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:03:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-1789) 200 Response with Vary header does not invalidate cached 404 response without - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:13:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-1630) 304 response causes multiple copies of file in cache - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:17:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2234) remove dependency on commons-codec in older versions of http-client - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:20:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2151) Optionally use JSSE inbuilt endpoint identification - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:23:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-1471) ResponseCachingPolicy - eliminate boxing and HashSet - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:24:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-1099) Overriding Caching Policies - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 09:26:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-1630) 304 response causes multiple copies of file in cache - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/12/30 10:47:00 UTC, 0 replies.