You are viewing a plain text version of this content. The canonical link for it is here.
- [GitHub] [httpcomponents-client] garydgregory merged pull request #465: Mostly missing Javadoc in org.apache.hc.client5.http.entity - posted by "garydgregory (via GitHub)" <gi...@apache.org> on 2023/07/02 20:31:09 UTC, 0 replies.
- Re: [ANNOUNCEMENT] HttpComponents Core 5.2.2 GA released - posted by Sandeep Gaur <sa...@gmail.com> on 2023/07/04 07:09:02 UTC, 4 replies.
- [jira] [Commented] (HTTPCORE-754) StrictConnPool unable to acquire lock under multi threaded application causing DeadlineTimeoutException exception being thrown - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/07/04 13:16:00 UTC, 4 replies.
- [GitHub] [httpcomponents-client] ok2c commented on a diff in pull request #462: HTTPCLIENT-2277: Implement Cache-Control Extension in Response Caching Policy. - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/04 13:37:30 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-754) StrictConnPool unable to acquire lock under multi threaded application causing DeadlineTimeoutException exception being thrown - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/06 08:01:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c opened a new pull request, #466: HTTPCLIENT-2277: Revision and simplification of the cache eviction logic - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/09 16:37:02 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2282) Handle java.net.SocketException: Connection reset more gracefully - posted by "Konrad Windszus (Jira)" <ji...@apache.org> on 2023/07/11 14:24:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2282) Handle java.net.SocketException: Connection reset more gracefully - posted by "Gary D. Gregory (Jira)" <ji...@apache.org> on 2023/07/11 15:05:00 UTC, 1 replies.
- [jira] [Updated] (HTTPCLIENT-2282) Handle java.net.SocketException: Connection reset more gracefully - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/11 15:30:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #466: HTTPCLIENT-2277: Revision and simplification of the cache eviction logic - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/11 16:21:38 UTC, 0 replies.
- Re: End of life of HttpCore and HttpClient 4.x - posted by Gary Gregory <ga...@gmail.com> on 2023/07/12 13:38:51 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2283) Missing option to configure charset for classic CloseableHttpClient - posted by "Dominik Derwiński (Jira)" <ji...@apache.org> on 2023/07/13 15:11:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2283) Missing option to configure charset for classic CloseableHttpClient - posted by "Dominik Derwiński (Jira)" <ji...@apache.org> on 2023/07/13 15:13:00 UTC, 2 replies.
- [jira] [Commented] (HTTPCLIENT-2283) Missing option to configure charset for classic CloseableHttpClient - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/13 16:00:00 UTC, 9 replies.
- [jira] [Resolved] (HTTPCLIENT-2283) Missing option to configure charset for classic CloseableHttpClient - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/13 16:00:00 UTC, 1 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2283) Missing option to configure charset for classic CloseableHttpClient - posted by "Dominik Derwiński (Jira)" <ji...@apache.org> on 2023/07/14 05:50:00 UTC, 0 replies.
- [jira] [Reopened] (HTTPCLIENT-2283) Missing option to configure charset for classic CloseableHttpClient - posted by "Dominik Derwiński (Jira)" <ji...@apache.org> on 2023/07/14 05:51:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] karlchan-cn opened a new pull request, #411: Lease connection using trylock with timeout of requesting a pool - posted by "karlchan-cn (via GitHub)" <gi...@apache.org> on 2023/07/18 04:40:32 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #411: Lease connection using trylock with timeout of requesting a pool - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/18 07:56:06 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c closed pull request #411: Lease connection using trylock with timeout of requesting a pool - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/18 07:56:07 UTC, 0 replies.
- HttpClient 5.2.2 release plans; Re: [ANNOUNCEMENT] HttpComponents Core 5.2.2 GA released - posted by Oleg Kalnichevski <ol...@apache.org> on 2023/07/18 08:09:57 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on a diff in pull request #466: HTTPCLIENT-2277: Revision and simplification of the cache eviction logic - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/19 00:03:02 UTC, 2 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #462: HTTPCLIENT-2277: Implement Cache-Control Extension in Response Caching Policy. - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/19 00:07:51 UTC, 0 replies.
- [GitHub] [httpcomponents-client] stanio commented on a diff in pull request #466: HTTPCLIENT-2277: Revision and simplification of the cache eviction logic - posted by "stanio (via GitHub)" <gi...@apache.org> on 2023/07/19 08:25:52 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on a diff in pull request #466: HTTPCLIENT-2277: Revision and simplification of the cache eviction logic - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/19 14:39:10 UTC, 2 replies.
- [GitHub] [httpcomponents-client] jvasileff opened a new pull request, #467: Per rfc2617, use the provided Response algorithm in the Request - posted by "jvasileff (via GitHub)" <gi...@apache.org> on 2023/07/19 16:52:29 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #467: Per rfc2617, use the provided Response algorithm in the Request - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/19 22:55:26 UTC, 0 replies.
- [GitHub] [httpcomponents-client] jvasileff commented on pull request #467: Per rfc2617, use the provided Response algorithm in the Request - posted by "jvasileff (via GitHub)" <gi...@apache.org> on 2023/07/19 23:51:43 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c merged pull request #466: HTTPCLIENT-2277: Revision and simplification of the cache eviction logic - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/20 07:26:24 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2277) HttpClient Cache conformance to RFC 9111 - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/07/20 07:27:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #462: HTTPCLIENT-2277: Implement Cache-Control Extension in Response Caching Policy. - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/20 07:29:05 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #467: Per rfc2617, use the provided Response algorithm in the Request - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/20 07:37:19 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ChristophKaser opened a new pull request, #468: Check for timeToLive == 0 - posted by "ChristophKaser (via GitHub)" <gi...@apache.org> on 2023/07/20 11:56:36 UTC, 0 replies.
- [GitHub] [httpcomponents-client] jvasileff commented on pull request #467: Per RFC 7616, use the provided Response algorithm in the Request - posted by "jvasileff (via GitHub)" <gi...@apache.org> on 2023/07/20 12:04:46 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c merged pull request #467: Per RFC 7616, use the provided Response algorithm in the Request - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/20 18:16:40 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2284) BasicHttpCacheStorage leaking variant keys in root response's variantMap - posted by "Pascal Lacombe (Jira)" <ji...@apache.org> on 2023/07/20 18:34:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2284) BasicHttpCacheStorage leaking variant keys in root response's variantMap - posted by "Pascal Lacombe (Jira)" <ji...@apache.org> on 2023/07/20 18:36:00 UTC, 2 replies.
- [GitHub] [httpcomponents-client] ok2c commented on a diff in pull request #468: Check for timeToLive == 0 - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/20 18:37:21 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on a diff in pull request #468: Check for timeToLive == 0 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/20 18:37:56 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2284) BasicHttpCacheStorage leaking variant keys in root response's variantMap - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/20 18:43:00 UTC, 5 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #462: RFC8246 HTTP Immutable Responses - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/20 18:55:12 UTC, 1 replies.
- [GitHub] [httpcomponents-client] ChristophKaser commented on a diff in pull request #468: Check for timeToLive == 0 - posted by "ChristophKaser (via GitHub)" <gi...@apache.org> on 2023/07/21 06:52:15 UTC, 1 replies.
- [jira] [Created] (HTTPCLIENT-2285) API compatibility reports not available - posted by "Konrad Windszus (Jira)" <ji...@apache.org> on 2023/07/21 09:49:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2285) API compatibility reports not available - posted by "Konrad Windszus (Jira)" <ji...@apache.org> on 2023/07/21 09:49:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2286) Support HTTP/2 via Classic APIs - posted by "Konrad Windszus (Jira)" <ji...@apache.org> on 2023/07/21 10:00:00 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c commented on pull request #462: RFC8246 HTTP Immutable Responses - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/22 10:59:17 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c merged pull request #468: Check for timeToLive == 0 - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/22 11:04:20 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2286) Support HTTP/2 via Classic APIs - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/22 11:11:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCLIENT-2285) API compatibility reports not available - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/22 13:21:00 UTC, 0 replies.
- [jira] [Created] (HTTPCORE-755) Connection gets closed prematurely before Decoder gets completed - posted by "Arunan Sugunakumar (Jira)" <ji...@apache.org> on 2023/07/24 09:28:00 UTC, 0 replies.
- [jira] [Comment Edited] (HTTPCLIENT-2284) BasicHttpCacheStorage leaking variant keys in root response's variantMap - posted by "Pascal Lacombe (Jira)" <ji...@apache.org> on 2023/07/24 15:19:00 UTC, 1 replies.
- [GitHub] [httpcomponents-client] arturobernalg merged pull request #462: RFC8246 HTTP Immutable Responses - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/24 20:36:50 UTC, 0 replies.
- [jira] [Commented] (HTTPCORE-755) Connection gets closed prematurely before Decoder gets completed - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/25 05:33:00 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2287) Advice needed on preserving MDC - posted by "Patrick Barry (Jira)" <ji...@apache.org> on 2023/07/25 13:30:00 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2287) Advice needed on preserving MDC - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/25 17:25:00 UTC, 1 replies.
- [jira] [Resolved] (HTTPCLIENT-2287) Advice needed on preserving MDC - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/25 17:26:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] arturobernalg opened a new pull request, #412: HTTPCORE-746 - Refactor Synchronized Blocks to Use ReentrantLock. - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/27 16:21:44 UTC, 0 replies.
- [GitHub] [httpcomponents-client] kervin521 commented on pull request #443: Bump download-maven-plugin from 1.6.8 to 1.7.0 - posted by "kervin521 (via GitHub)" <gi...@apache.org> on 2023/07/28 05:29:08 UTC, 0 replies.
- JDK 22 is in Rampdown Phase 2 | Annotation Processing Change Heads-up - posted by David Delabassee <da...@oracle.com> on 2023/07/28 09:27:19 UTC, 0 replies.
- [GitHub] [httpcomponents-client] arturobernalg commented on pull request #443: Bump download-maven-plugin from 1.6.8 to 1.7.0 - posted by "arturobernalg (via GitHub)" <gi...@apache.org> on 2023/07/28 12:13:46 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] opened a new pull request, #469: Bump com.googlecode.maven-download-plugin:download-maven-plugin from 1.6.8 to 1.7.1 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/07/28 13:24:14 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] commented on pull request #443: Bump download-maven-plugin from 1.6.8 to 1.7.0 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/07/28 13:24:16 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] closed pull request #443: Bump download-maven-plugin from 1.6.8 to 1.7.0 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/07/28 13:24:18 UTC, 0 replies.
- [GitHub] [httpcomponents-client] dependabot[bot] opened a new pull request, #470: Bump org.junit:junit-bom from 5.9.3 to 5.10.0 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/07/28 13:24:22 UTC, 0 replies.
- [jira] [Assigned] (HTTPCORE-747) Some flaky tests - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/07/28 14:08:00 UTC, 0 replies.
- [jira] [Resolved] (HTTPCORE-747) Some flaky tests - posted by "Arturo Bernal (Jira)" <ji...@apache.org> on 2023/07/28 14:09:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] dependabot[bot] opened a new pull request, #413: Bump org.junit:junit-bom from 5.9.3 to 5.10.0 - posted by "dependabot[bot] (via GitHub)" <gi...@apache.org> on 2023/07/28 14:36:21 UTC, 0 replies.
- [jira] [Created] (HTTPCLIENT-2288) DefaultHttpClientConnectionOperator - posted by "Liam Miller-Cushon (Jira)" <ji...@apache.org> on 2023/07/29 01:28:00 UTC, 0 replies.
- [jira] [Updated] (HTTPCLIENT-2288) Retry logic in DefaultHttpClientConnectionOperator doesn't handle SocketException - posted by "Liam Miller-Cushon (Jira)" <ji...@apache.org> on 2023/07/29 01:35:00 UTC, 3 replies.
- [GitHub] [httpcomponents-client] cushon opened a new pull request, #471: HTTPCLIENT-2288 - Retry logic in DefaultHttpClientConnectionOperator doesn't handle SocketException - posted by "cushon (via GitHub)" <gi...@apache.org> on 2023/07/29 03:09:32 UTC, 0 replies.
- [GitHub] [httpcomponents-client] ok2c merged pull request #471: HTTPCLIENT-2288 - Retry logic in DefaultHttpClientConnectionOperator doesn't handle SocketException - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/29 07:40:35 UTC, 0 replies.
- [jira] [Commented] (HTTPCLIENT-2288) Retry logic in DefaultHttpClientConnectionOperator doesn't handle SocketException - posted by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2023/07/29 07:41:00 UTC, 1 replies.
- [jira] [Resolved] (HTTPCLIENT-2288) Retry logic in DefaultHttpClientConnectionOperator doesn't handle SocketException - posted by "Oleg Kalnichevski (Jira)" <ji...@apache.org> on 2023/07/29 07:46:00 UTC, 0 replies.
- [GitHub] [httpcomponents-core] ok2c commented on pull request #412: HTTPCORE-746 - Refactor Synchronized Blocks to Use ReentrantLock. - posted by "ok2c (via GitHub)" <gi...@apache.org> on 2023/07/29 07:54:10 UTC, 0 replies.