You are viewing a plain text version of this content. The canonical link for it is here.
- [httpcomponents-core] branch dependabot/maven/io.fabric8-docker-maven-plugin-0.42.0 created (now 9748d1474) - posted by gi...@apache.org on 2023/03/03 14:58:20 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Fix Heuristic caching for URIs with query strings by adhering to RFC 2616 Section 13.9. The change is based on the fact that caches MUST NOT treat responses to such URIs as fresh unless the server provides an explicit expiration time. However, the updated RFC 7234 note indicates that it would be ok to introduce a configuration option that relaxed this rule. Therefore, a new configuration option is added to allow HTTP/1.1 responses with query strings to be cached. - posted by ol...@apache.org on 2023/03/06 13:40:38 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Workaround for URL quoting issue with LLv6 host literals. Due to an issue with URL quoting for LLv6 host literals, the original implementation of SystemDefaultDnsResolver does not support constructing URLs with LLv6 literals that have a ZoneID. This commit implements a workaround that strips the ZoneID from LLv6 literals before resolving them. This allows URLs with LLv6 literals to be constructed without quoting the ZoneID. Note that this workaround does not fully comply with RFC 6874, but [...] - posted by ol...@apache.org on 2023/03/06 13:41:08 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Fix handling of cached responses with variants and different ETag values. Previously, the getCacheEntry method was not correctly selecting the matching variant for a given request, which led to incorrect behavior when serving cached responses. This commit improves the method's logic to correctly identify the cache entry using the request's cache key, and then select the variant with the matching ETag value. If no matching variant is found, the cache entry is considered stale and a new resp [...] - posted by ol...@apache.org on 2023/03/12 09:15:10 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated (20bdd46c4 -> ee185b566) - posted by ol...@apache.org on 2023/03/12 09:23:21 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated (ee185b566 -> c3efc6e87) - posted by ol...@apache.org on 2023/03/12 09:33:23 UTC, 0 replies.
- [httpcomponents-client] 01/01: Allow certain responses from a POST to be cacheable. - posted by ol...@apache.org on 2023/03/12 09:33:24 UTC, 0 replies.
- [httpcomponents-core] branch master updated (b26a55907 -> 946f8b3f2) - posted by ol...@apache.org on 2023/03/13 14:25:15 UTC, 0 replies.
- [httpcomponents-core] 01/06: Updated release notes for HttpCore 5.2.1 release - posted by ol...@apache.org on 2023/03/13 14:25:16 UTC, 0 replies.
- [httpcomponents-core] 02/06: Upgraded HttpCore version to 5.2.2-SNAPSHOT - posted by ol...@apache.org on 2023/03/13 14:25:17 UTC, 0 replies.
- [httpcomponents-core] 03/06: Do not duplicate the HttpMessage instance variable slot in subclasses of AbstractMessageWrapper. - posted by ol...@apache.org on 2023/03/13 14:25:18 UTC, 0 replies.
- [httpcomponents-core] 04/06: Upgraded API compatibility level to 5.2 - posted by ol...@apache.org on 2023/03/13 14:25:19 UTC, 0 replies.
- [httpcomponents-core] 05/06: HTTPCORE-733: BasicAsyncEntityProducer sends an extra trailing 0 with UTF-8 encoded content - posted by ol...@apache.org on 2023/03/13 14:25:20 UTC, 0 replies.
- [httpcomponents-core] 06/06: The official document POST example incorrectly calls the GET method. For beginners, it is necessary to revise - posted by ol...@apache.org on 2023/03/13 14:25:21 UTC, 0 replies.
- [httpcomponents-core] branch 5.3.x updated (a990a75f3 -> f14f7b0c6) - posted by ol...@apache.org on 2023/03/13 14:27:55 UTC, 0 replies.
- [httpcomponents-core] 01/06: Upgraded HttpCore version to 5.3-alpha1-SNAPSHOT - posted by ol...@apache.org on 2023/03/13 14:27:56 UTC, 0 replies.
- [httpcomponents-core] 02/06: Added ViaRequest interceptor. - posted by ol...@apache.org on 2023/03/13 14:27:57 UTC, 0 replies.
- [httpcomponents-core] 03/06: Fix the issue with invalid scoped IPv6 addresses in InetAddressUtils. - posted by ol...@apache.org on 2023/03/13 14:27:58 UTC, 0 replies.
- [httpcomponents-core] 04/06: Use either US-ASCII or UTF-8 encoding for text where approriate - posted by ol...@apache.org on 2023/03/13 14:27:59 UTC, 0 replies.
- [httpcomponents-core] 05/06: Add a "Forwarded" HttpRequestInterceptor to add the "Forwarded" HTTP header. - posted by ol...@apache.org on 2023/03/13 14:28:00 UTC, 0 replies.
- [httpcomponents-core] 06/06: Add support for Internationalized Domain Names (IDN) - posted by ol...@apache.org on 2023/03/13 14:28:01 UTC, 0 replies.
- [httpcomponents-client] branch master updated (e9630a4d3 -> 5896c20cb) - posted by ol...@apache.org on 2023/03/13 14:44:23 UTC, 0 replies.
- [httpcomponents-client] 01/11: Fix minor typo in Javadoc - posted by ol...@apache.org on 2023/03/13 14:44:24 UTC, 0 replies.
- [httpcomponents-client] 02/11: Pass HttpContext to SSLConnectionSocketFactory#prepareSocket method (#404) - posted by ol...@apache.org on 2023/03/13 14:44:25 UTC, 0 replies.
- [httpcomponents-client] 03/11: Upgraded API compatibility level to 5.2 - posted by ol...@apache.org on 2023/03/13 14:44:26 UTC, 0 replies.
- [httpcomponents-client] 04/11: Upgraded HttpCore to version 5.2.1 - posted by ol...@apache.org on 2023/03/13 14:44:27 UTC, 0 replies.
- [httpcomponents-client] 05/11: Camel case names - posted by ol...@apache.org on 2023/03/13 14:44:28 UTC, 0 replies.
- [httpcomponents-client] 06/11: Make inner classes static (#405) - posted by ol...@apache.org on 2023/03/13 14:44:29 UTC, 0 replies.
- [httpcomponents-client] 07/11: Remove unnecessary declarations. - posted by ol...@apache.org on 2023/03/13 14:44:30 UTC, 0 replies.
- [httpcomponents-client] 08/11: Updated NOTICE to 2023 - posted by ol...@apache.org on 2023/03/13 14:44:31 UTC, 0 replies.
- [httpcomponents-client] 09/11: chore: update ClientProxyAuthenticationExample - posted by ol...@apache.org on 2023/03/13 14:44:32 UTC, 0 replies.
- [httpcomponents-client] 10/11: Hygiene - remove unused private fields - posted by ol...@apache.org on 2023/03/13 14:44:33 UTC, 0 replies.
- [httpcomponents-client] 11/11: Remove dependency not used - posted by ol...@apache.org on 2023/03/13 14:44:34 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated (c3efc6e87 -> f7ff1088c) - posted by ol...@apache.org on 2023/03/13 14:46:16 UTC, 0 replies.
- [httpcomponents-client] 01/10: Credentials interface should be able to represent different types of user credentials including token based with no password - posted by ol...@apache.org on 2023/03/13 14:46:17 UTC, 0 replies.
- [httpcomponents-client] 02/10: Removed references in specific RFCs - posted by ol...@apache.org on 2023/03/13 14:46:18 UTC, 0 replies.
- [httpcomponents-client] 03/10: Normalize scheme name in AuthScope - posted by ol...@apache.org on 2023/03/13 14:46:19 UTC, 0 replies.
- [httpcomponents-client] 04/10: Made authenticating decorators capable of supporting different authentication schemes - posted by ol...@apache.org on 2023/03/13 14:46:20 UTC, 0 replies.
- [httpcomponents-client] 05/10: New Authenticator interface method to return an auth result with additional challenge parameters - posted by ol...@apache.org on 2023/03/13 14:46:21 UTC, 0 replies.
- [httpcomponents-client] 06/10: BEARER auth scheme support (RFC 6750) - posted by ol...@apache.org on 2023/03/13 14:46:22 UTC, 0 replies.
- [httpcomponents-client] 07/10: Fix Heuristic caching for URIs with query strings by adhering to RFC 2616 Section 13.9. The change is based on the fact that caches MUST NOT treat responses to such URIs as fresh unless the server provides an explicit expiration time. However, the updated RFC 7234 note indicates that it would be ok to introduce a configuration option that relaxed this rule. Therefore, a new configuration option is added to allow HTTP/1.1 responses with query strings to be cached. - posted by ol...@apache.org on 2023/03/13 14:46:23 UTC, 0 replies.
- [httpcomponents-client] 08/10: Workaround for URL quoting issue with LLv6 host literals. Due to an issue with URL quoting for LLv6 host literals, the original implementation of SystemDefaultDnsResolver does not support constructing URLs with LLv6 literals that have a ZoneID. This commit implements a workaround that strips the ZoneID from LLv6 literals before resolving them. This allows URLs with LLv6 literals to be constructed without quoting the ZoneID. Note that this workaround does not fully comply with RFC 6874, but [...] - posted by ol...@apache.org on 2023/03/13 14:46:24 UTC, 0 replies.
- [httpcomponents-client] 09/10: Fix handling of cached responses with variants and different ETag values. Previously, the getCacheEntry method was not correctly selecting the matching variant for a given request, which led to incorrect behavior when serving cached responses. This commit improves the method's logic to correctly identify the cache entry using the request's cache key, and then select the variant with the matching ETag value. If no matching variant is found, the cache entry is considered stale and a new resp [...] - posted by ol...@apache.org on 2023/03/13 14:46:25 UTC, 0 replies.
- [httpcomponents-client] 10/10: Allow certain responses from a POST to be cacheable. - posted by ol...@apache.org on 2023/03/13 14:46:26 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Fix issue with duplicate parsing of Cache-Control header - posted by ol...@apache.org on 2023/03/15 18:19:58 UTC, 0 replies.
- Build failed in Jenkins: HttpComponents » HttpComponents Client 5.3.x #5 - posted by Apache Jenkins Server <je...@builds.apache.org> on 2023/03/16 00:56:20 UTC, 0 replies.
- [httpcomponents-client] branch 4.5.x updated: HTTPCLIENT-2263: Cannot Access Trailer-Headers in Chunked transfer-encoding (#425) - posted by ol...@apache.org on 2023/03/16 13:46:30 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Enhance ContentResponseHandler to be fault-tolerant - posted by ol...@apache.org on 2023/03/16 16:09:13 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Avoid using deprecated DateUtils. - posted by ol...@apache.org on 2023/03/16 16:09:56 UTC, 0 replies.
- [httpcomponents-core] branch 5.3.x updated: Use Timeout#INFINITE instead of Timeout#DISABLED for network operations - posted by ol...@apache.org on 2023/03/16 16:29:29 UTC, 0 replies.
- Build failed in Jenkins: HttpComponents » HttpComponents Client 5.3.x Java17 #6 - posted by Apache Jenkins Server <je...@builds.apache.org> on 2023/03/17 00:12:19 UTC, 0 replies.
- Build failed in Jenkins: HttpComponents » HttpComponents Client 5.3.x #6 - posted by Apache Jenkins Server <je...@builds.apache.org> on 2023/03/17 00:56:23 UTC, 0 replies.
- [httpcomponents-client] branch master updated: HTTPCLIENT-2262: Corrected RequestConfig#connectionRequestTimeout javadocs - posted by ol...@apache.org on 2023/03/17 10:28:46 UTC, 0 replies.
- Build failed in Jenkins: HttpComponents » HttpComponents Client 5.2.x #119 - posted by Apache Jenkins Server <je...@builds.apache.org> on 2023/03/17 12:23:38 UTC, 0 replies.
- [httpcomponents-client] branch 5.3.x updated: Add support for preamble and epilogue in multipart entities - posted by ol...@apache.org on 2023/03/23 13:27:24 UTC, 0 replies.
- Jenkins build is back to normal : HttpComponents » HttpComponents Client 5.3.x Java17 #7 - posted by Apache Jenkins Server <je...@builds.apache.org> on 2023/03/24 00:18:22 UTC, 0 replies.
- Build failed in Jenkins: HttpComponents » HttpComponents Client 5.3.x #7 - posted by Apache Jenkins Server <je...@builds.apache.org> on 2023/03/24 00:56:22 UTC, 0 replies.
- [httpcomponents-core] branch 5.3.x updated: Return emptySet or emptyList instead of null to honor contract for return type - posted by ol...@apache.org on 2023/03/27 10:58:10 UTC, 0 replies.