You are viewing a plain text version of this content. The canonical link for it is here.
- [sis] branch geoapi-4.0 updated: Set GCOM-C coordinate reference system to WGS84, as specified in their documentation. - posted by de...@apache.org on 2020/09/01 08:56:34 UTC, 0 replies.
- [sis] branch feat/sourceDomainExpansion updated (6e8b8eb -> fbd5f31) - posted by js...@apache.org on 2020/09/01 12:03:26 UTC, 0 replies.
- [sis] 01/02: Merge branch 'geoapi-4.0' into feat/sourceDomainExpansion - posted by js...@apache.org on 2020/09/01 12:03:27 UTC, 0 replies.
- [sis] 02/02: Add coverage query expansion test cases, add readonly memory grid resource - posted by js...@apache.org on 2020/09/01 12:03:28 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add a "Copy > Coordinates of here" menu item for making easier to check position on e.g. Google Map. - posted by de...@apache.org on 2020/09/01 16:05:25 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (0a02a2a -> acb8871) - posted by de...@apache.org on 2020/09/02 14:09:54 UTC, 0 replies.
- [sis] 01/04: Add a menu item for coyping the path to a file. - posted by de...@apache.org on 2020/09/02 14:09:55 UTC, 0 replies.
- [sis] 02/04: More accurate identification of error when image size is not an integer multiple of tile size. - posted by de...@apache.org on 2020/09/02 14:09:56 UTC, 0 replies.
- [sis] 03/04: More informative error message when an envelope or position given to a GeneralEnvelope does not have the expected CRS. - posted by de...@apache.org on 2020/09/02 14:09:57 UTC, 0 replies.
- [sis] 04/04: GridDerivation.subgrid[…) needs to transform the `areaOfInterest` envelope if the CRSs are not equal. - posted by de...@apache.org on 2020/09/02 14:09:58 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (acb8871 -> 4a44a2b) - posted by de...@apache.org on 2020/09/03 13:51:09 UTC, 0 replies.
- [sis] 01/04: Refactor the "Copy file path" action in a separated class with better management of File/URI conversions. - posted by de...@apache.org on 2020/09/03 13:51:10 UTC, 0 replies.
- [sis] 02/04: Make the `bounds` argument optional, with default to the full image. - posted by de...@apache.org on 2020/09/03 13:51:11 UTC, 0 replies.
- [sis] 03/04: If the image to resample is too small for the specified interpolation, use nearest neighbor. It happens if user tries to apply a bilinear interpolation on an image of size 1×1 pixel (an image of such size if typically a template for ColorModel and SampleModel). - posted by de...@apache.org on 2020/09/03 13:51:12 UTC, 0 replies.
- [sis] 04/04: Fix a 0.5 pixel offset when Interpolation.NEAREST is used. - posted by de...@apache.org on 2020/09/03 13:51:13 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Documentation fixes and renaming of `WraparoundTransform.create(…)` for clarity. - posted by de...@apache.org on 2020/09/03 17:37:43 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Missing interpolation values in last row and last column of destination image when interpolation is nearest-neighbor and the optimized path is not used. - posted by de...@apache.org on 2020/09/04 14:04:09 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: The name of CRS produced by `AbstractCRS.forConvention(…)` should not contain an "EPSG" codespace. - posted by de...@apache.org on 2020/09/04 17:50:26 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Fix a StackOverflowError in `tryConcatenate(…)`. Add a method for adjusting wraparound range based on a target domain. - posted by de...@apache.org on 2020/09/06 14:55:09 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Initial support of wraparound axes during raster resampling. - posted by de...@apache.org on 2020/09/07 12:12:40 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add a `GridGeometry.createTransformTo(GridGeometry target)` method. - posted by de...@apache.org on 2020/09/07 14:20:55 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (866e380 -> 4fbf175) - posted by de...@apache.org on 2020/09/07 14:23:28 UTC, 0 replies.
- [sis] 01/01: Add a `GridGeometry.createTransformTo(GridGeometry target)` method. - posted by de...@apache.org on 2020/09/07 14:23:29 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Make wraparound checks more robust by comparing "transform without wraparound" with "transform with wraparound". - posted by de...@apache.org on 2020/09/09 10:37:50 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Apply wraparound on geographic coordinates shown in status bar. Prepare `RenderedData` for wraparound axes (not yet completed). Convenience method for fetching DefaultMathTransformFactory. - posted by de...@apache.org on 2020/09/09 17:52:13 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (c7a721a -> e11ba91) - posted by de...@apache.org on 2020/09/10 14:50:01 UTC, 0 replies.
- [sis] 01/01: Merge branch 'feat/sourceDomainExpansion' into geoapi-4.0. Reviewed some `GridExtent` and `AbstractGridResource` methods for consistency and for making little bit easier to implement `MemoryGridResource`. - posted by de...@apache.org on 2020/09/10 14:50:02 UTC, 0 replies.
- [sis] branch feat/sourceDomainExpansion deleted (was fbd5f31) - posted by de...@apache.org on 2020/09/10 14:53:00 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Make conditional an assertion that may become invalid under JDK 16. https://bugs.openjdk.java.net/browse/JDK-8166038 - posted by de...@apache.org on 2020/09/10 21:51:48 UTC, 0 replies.
- [sis] branch fix/sourceExpansion created (now 53b168a) - posted by js...@apache.org on 2020/09/11 12:54:24 UTC, 0 replies.
- [sis] 01/01: Add test case breaking source domain expansion - posted by js...@apache.org on 2020/09/11 12:54:25 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (0b29f05 -> 894384d) - posted by de...@apache.org on 2020/09/11 17:51:21 UTC, 0 replies.
- [sis] 01/02: Merge branch 'fix/sourceExpansion' into geoapi-4.0 together with the fix for the problem shown by the new test. - posted by de...@apache.org on 2020/09/11 17:51:22 UTC, 0 replies.
- [sis] 02/02: Add checks against empty area of interest during pixel iteration. - posted by de...@apache.org on 2020/09/11 17:51:23 UTC, 0 replies.
- [sis] branch fix/sourceExpansion deleted (was 53b168a) - posted by de...@apache.org on 2020/09/11 17:52:08 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (894384d -> a56b98f) - posted by de...@apache.org on 2020/09/12 14:47:27 UTC, 0 replies.
- [sis] 01/02: Undeprecate `GridExtent.expand(long...)` given its similarity with method below. Refactor `GridExtent.grow(boolean, boolean long...)` as `expand(long[], long[])`. Add tests. - posted by de...@apache.org on 2020/09/12 14:47:28 UTC, 0 replies.
- [sis] 02/02: Disable interpolations on image using an IndexColorModel. - posted by de...@apache.org on 2020/09/12 14:47:29 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: GridGeometry.createTransformTo(…) was not concatenating the right transform. - posted by de...@apache.org on 2020/09/14 11:12:35 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (da1d008 -> c34da9e) - posted by de...@apache.org on 2020/09/15 12:51:53 UTC, 0 replies.
- [sis] 01/03: Move `MathTransformsOrFactory` in an internal package where it can be shared with classes in different packages. - posted by de...@apache.org on 2020/09/15 12:51:54 UTC, 0 replies.
- [sis] 02/03: Remove the use of `MathTransformFactory` in WraparoundTransform (except in `tryConcatenate`). All classes using WraparoundTransform had no particular factory to specify. Remove corresponding `throws FactoryException` statements. - posted by de...@apache.org on 2020/09/15 12:51:55 UTC, 0 replies.
- [sis] 03/03: GridDerivation.subgrid(GridGeometry) should support coverage spanning the anti-meridian. - posted by de...@apache.org on 2020/09/15 12:51:56 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: More robust determination of whether an axis should be handled as a wraparound axis. - posted by de...@apache.org on 2020/09/15 19:06:08 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Move `WraparoundTransform.isNeeded(…)` method to `CoordinateOperationFinder`. This moves simplifies the code by allowing more direct uses of fields or methods instead than indirect uses through `java.util.function.Supplier`. - posted by de...@apache.org on 2020/09/16 14:52:08 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (4cca7a6 -> bb7c99d) - posted by de...@apache.org on 2020/09/16 17:55:37 UTC, 0 replies.
- [sis] 01/02: Enable optimization in `TranslationTransform` which were missed. - posted by de...@apache.org on 2020/09/16 17:55:38 UTC, 0 replies.
- [sis] 02/02: Replace the use of `Math.floor(…)` by `Math.IEEEremainder(…) in `WraparoundTransform` for reducing rounding errors. - posted by de...@apache.org on 2020/09/16 17:55:39 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Bug fixes in optimizations (translation case not always detected, existing transforms not reused). - posted by de...@apache.org on 2020/09/16 19:19:54 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Minor documentation adjustments. - posted by de...@apache.org on 2020/09/16 21:17:42 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (04a642a -> bbf046c) - posted by de...@apache.org on 2020/09/17 11:11:32 UTC, 0 replies.
- [sis] 01/02: Formatting (no code change). - posted by de...@apache.org on 2020/09/17 11:11:33 UTC, 0 replies.
- [sis] 02/02: Bug fix in the determination of matrix coefficients that we can move around `WraparoundTransform`. - posted by de...@apache.org on 2020/09/17 11:11:34 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: More extensive tests of whether "wraparound axes" may occurs when a map projection is involved in the transformation chain. - posted by de...@apache.org on 2020/09/21 12:37:48 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: fix(Feature): slight improvement on feature type builder: automatically replace primitive value class of attributes by their boxed equivalent - posted by am...@apache.org on 2020/09/23 10:01:53 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (de1ac25 -> 3dff7c6) - posted by de...@apache.org on 2020/09/23 17:23:47 UTC, 0 replies.
- [sis] 01/02: Parameterize `Numbers.primitiveToWrapper(Class)` method. It avoids "unsafe cast" warning in `FeatureTypebuilder.addAttribute(…)`. - posted by de...@apache.org on 2020/09/23 17:23:48 UTC, 0 replies.
- [sis] 02/02: Add a `GridOrientation` argument to `GridGeometry(GridExtent, Envelope)` constructor. The intent is to make this constructor more useful for expressing "desired" geometry, as opposed to geometry of preexisting data. - posted by de...@apache.org on 2020/09/23 17:23:49 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (3dff7c6 -> dceffce) - posted by de...@apache.org on 2020/09/24 14:44:52 UTC, 0 replies.
- [sis] 01/02: API change: rename GridOrientation.HOMOTHETIC as HOMOTHETY. Add an argument in `GridExtent.cornerToCRS(…) for axis order. - posted by de...@apache.org on 2020/09/24 14:44:53 UTC, 0 replies.
- [sis] 02/02: Add a `DISPLAY` enumeration value in `GridOrientation`. - posted by de...@apache.org on 2020/09/24 14:44:54 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add a GridOrientation.DISPLAY_GRID enumeration value. - posted by de...@apache.org on 2020/09/25 12:49:09 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Add a note in situations where `GridGeometry` crosses the anti-meridian. Documentation and minor accuracy improvement. - posted by de...@apache.org on 2020/09/25 17:25:46 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated (636534f -> 514e928) - posted by de...@apache.org on 2020/09/26 22:05:18 UTC, 0 replies.
- [sis] 01/03: More complete detection of wraparound cases when adding a note in `toString()` representation. - posted by de...@apache.org on 2020/09/26 22:05:19 UTC, 0 replies.
- [sis] 02/03: Improve the WKT formatting of `WraparoundTransform` for easier debugging. - posted by de...@apache.org on 2020/09/26 22:05:20 UTC, 0 replies.
- [sis] 03/03: Enable a Mollweide projection test. - posted by de...@apache.org on 2020/09/26 22:05:21 UTC, 0 replies.
- [sis] branch refactor/strict_storage_connector created (now dbeef90) - posted by am...@apache.org on 2020/09/28 14:25:54 UTC, 0 replies.
- [sis] 01/01: feat(Storage): Add an extension of storage connector with fail-fast behaviors - posted by am...@apache.org on 2020/09/28 14:25:55 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Deeper analysis of situations where a wraparound may occur during the transformation of a `GridGeometry` envelope. We must be careful to not apply too large translations on envelope corners: a lower-left corner should not become greater than upper-right corner for example. - posted by de...@apache.org on 2020/09/28 18:48:14 UTC, 0 replies.
- [sis] branch geoapi-4.0 updated: Use NaN for "no source median" to distinguish from 0. - posted by de...@apache.org on 2020/09/29 17:36:28 UTC, 0 replies.